Activation key's content section not listing all release versions availables

Foreman nightly distribution. Products for CentOS7 and 8 correctly synchronized. While creating/updating an Activation Key, some release versions for CentOS are not shown under Activation Key Content/Release Version drop down menu.

Anyone, any idea?

This release version is really only used for RHEL content, and not applicable for centos repositories (or any custom repositories for that matter). You can safely ignore this and it shouldn’t really affect custom repositories.

Fact is that i can’t figure out why my servers can only see a little number of packages related to the entire repository on the content view. To be more clear: that’s the content view:

If i list the repo on the server attached to the content view, i receive this:

As you can see, AppStream status report 674 packages while i should be able to watch more than 5000 packages

However: other content views work as expected, for other CentOS major releases, and the only glaring difference with that one resides in fact that i’m not able to set the “Release version” in the “Activation Key Content”

Hope to have been clear

Did you create any filters for this content view?

Can you show the content view version details page to see the counts within the content view version that is in that host’s lifecycle environment?

There are no filters, but maybe you could be more specific on what you are refering.

Here the content view details page:

If you click on version 6.0, you’ll see what is actually in the repositories in that CV version, not the contents of the library repositories

And if i click on version 6 i actually see all of the packages there should be, as follows

Let me pull down centos 8 and see if i can reproduce,

I tried with just the base os repo and my client fully saw all 2847 packages (as i can see via yum repolist). Appstream will always reflect a different count with how modules work.

Have you tried doing a ‘yum clean all’ on the client and seeing if ‘yum repolist’ show the correct count?

Yes i have, with no luck
I really can’t figure out what could be wrong

Have you sync’ed the official stream from CentOS site?

I synced it from here:

Can you try selecting “Regenerate Repository Metadata” from the Content View version Actions drop down?

Wait for the task to complete and then try a yum clean all && yum repolist

Done, but still the same.

Can you paste the /etc/yum.repos.d/redhat.repo file from that client?

First and third omissis are the name of the organization. The server name, after https is the correct FQDN of Foreman/Katello server.

You found the glitch, if i point the baseurl in my web browser:

but if i then try to follow the path (packages images or whatever else)

is there a way to correct the URL forge?

Hello, I have been trying to find how to set release versions using Foreman and CentOS and have come up blank (which most people saying its not possible or its a RHEL only thing) your image clearly shows that release versions should work

Can you talk me through how you set up your repo to list those release versions

“Help me Obi ban, you are my only hope!”

For interest, I do the following:

Create Product
Add 2 repos (BaseOS and AppStreamOS)
Create Content View

But I don’t see the release versions at all