Alllmost have Suse SLES15 SP4 client working but zypper says katello repos are "temporarily unaccessible"


Getting SLES 15 SP4 content and client working has been problematic, but I am almost there.

I first hit a bug in the SCC manager in which a button remained greyed out and i was unable to select SLES content to sync, but awsm developer Nadja fixed that bug and gave me brand new rubygem-foreman_scc_manager-2.3.0-1.fm3_8.el8.noarch which resolved the issue and allowed me to sync my SLES 15 SP4 products.

I then obtained subscription-manager from “Index of /SLES15SP4” repo but that repo failed to provide dependencies python3-iniparse and python3-ethtool, so i obtained
python3-iniparse-0.5-lp154.5.2.noarch.rpm from
python3-ethtool-0.15-lp154.2.5.x86_64.rpm from State of 15.4 for devel:languages:python:backports / python-ethtool - openSUSE Build Service

This allowed me to successfully execute the katello-rhsm-consumer script obtained from https://myforemanserver/pub/katello-rhsm-consumer

And then I was able to run subscription-manager on SLES15 SP4 client to register client to foreman/katello, and then install katello-host-tools and everything looks good.

So I have a SLES15 SP4 client registered to foreman/katello and have subscribed it to content view & it can see repos when i run “zypper repos”, that much works flawlessly.

But when i run “zypper refresh” to get detailed info from each repo, all the foreman/katello repos fail with

Repository 'SLE-Module-Server-Applications15-SP4-Updates for sle-15-x86_64' is invalid.
[rhsm:censored_Server_Applications_Module_15_SP4_x86_64_id_2307__2307_SLE-Module-Server-Applications15-SP4-Updates_for_sle-15-x86_64|https://censored/pulp/content/censored/Dev/SLES_15_SP4_All/custom/Server_Applications_Module_15_SP4_x86_64_id_2307_/2307_SLE-Module-Server-Applications15-SP4-Updates_for_sle-15-x86_64?ssl_verify=host&ssl_capath=%2Fetc%2Frhsm%2Fca&ssl_clientkey=%2Fetc%2Fpki%2Fentitlement%2F8921089470967225934-key.pem&ssl_clientcert=%2Fetc%2Fpki%2Fentitlement%2F8921089470967225934.pem] Valid metadata not found at specified URL

Is this just some minor SSL, or certificate or entitlement issue?
Does anyone have any idea how to investigate or propitiate the IT gods sufficiently to resolve this issue?

Many thanks for any assistance,

Expected outcome:
zypper refresh succeeds and i can then zypper install or zypper patch/update from the repos.

Foreman and Proxy versions:


Foreman and Proxy plugin versions:

Distribution and version:
server: foreman/katello on red Hat EL9.2
client: SLES15 SP4

Other relevant data:

Woops, sorry, brainfart.
The server is on EL8.8, not 9.2.