Am new to Katello

Upgrading the OS of existing hosts . I have multiple hosts managed by Katello . I can see half of them are with Rocky linux 8.8 version and for few it is set with Rocky linux 8.7 . Now I would like to move the Rocky linux 8.7 VMs to Rocky linux 8.8 .
Expected outcome: Upgrade is completed

Foreman and Proxy versions: foreman-3.4.1-1.

**Foreman and Proxy plugin versions:**foreman-proxy-3.4.1-1

Distribution and version:

Other relevant data:
Since am new to Katello would like to know the steps how exactly to do this migration for VMs to get the OS version to be patched . Same time there is no pending packages/erratas available to be installed for the VMs with Rocky 8.7 OS .


So as Rocky Linux just rolls over the repos when the next minor release gets released, which upstream repo path did you use? /pub/rocky/ … /BaseOS/x86_64/os/
Just 8 would be the correct thing to use, if you are using 8.7 I highly discourage the usage of this as, there won’t be any updates as soon as the next minor release appears and you would have to manually change it to 8.8 and further to get more updates. (beside this major.minor release path getting moved to the vault shortly after)
But in case you are using just 8 then you already have the 8.8 packages in your repos if you synced after May. (and promoted the content to available/used Content Views) And then it’s just the package update away. (either via the package update job templates in Katello or a dnf update on the system) No special migration needed like with SLES (it’s SP migration called there)

This also applies for some other EL distros like Almalinux or CentOS Stream, and I believe also with a normal RHEL subscription (I would have liked to answer that question with more confidence for RHEL but I asked this question the first time myself as well now, and don’t have the needed Satellite subscription around)

1 Like

@lumarel tried to update using package update and given the rocky 8.8 package repo and release package name but it says package action failed and exiting since no packages marked for upgrade

Okay… could you give us a glimpse into how you configured your repos on that system?
I mean I imagine you would have at least configured the following to make it work:

  • configured the repos in Katello like mentioned here: Managing Content
  • joined the machine to Katello
  • made sure the repos are added to the host in Katello
  • removed the local repos on the machine itself (or used the disable all local repos property in the subscription-manager.conf for dnf)

Or could you show us some output, it’s very vague up to now?

@lumarel This setup initially managed by my predecessors and it is something new I have picked up . The requirement is to update the OS version of compute engines to Rocky 8.8 from 8.7 . In current setup only two VMs are with 8.7 . I can see the repo sets for all the machines are same there is nothing explicitly differs between them except the installed rocky release package versions alone .
When I get into the VM with 8.7 version and perform dnf update it says nothing to do and when i try to execute update package job from Katello also it says same message. When I check in OS section in katello I can see only two Old VMs are under 8.7 while other VMs are in 8.8 . So was wondering if there is any way we can promote this!!! And I can see in content view we do not have anything except the default library. In this case should I try create a new host only for the updated OS to be reflected ? Sorry for being a noob . Was checking if there is any documentation in Katello site but unfortunately was not able to get anything.

Adding to that I have a multiple host collection . For instance in host collection only one server is with 8.7 version while other 6 hosts are with 8.8 versions.

You must have overlooked the extensive documentation on Foreman documentation: 3.7 :slight_smile:

And okay, this sounds like the packages are already updated on all machines, could it be that there is a missing restart for these 2 8.7 machines? Because the shown version only changes when the new kernel is booted.

The reboot is already done at the beginning itself but no luck . We are using Remote execution feature as far as I can see not the Katello agent.

When I check the installed packages in these 2 VMs I am unable to see rocky-release-8.8-1.7.el8.noarch , rocky-repos-8.8-1.7.el8.noarch , rocky-gpg-keys-8.8-1.7.el8.noarch similar to other VMs instead all I can see is below

rocky-release-8.7-1.2.el8.noarch , rocky-gpg-keys-8.7-1.2.el8.noarch , rocky-repos-8.7-1.2.el8.noarch.

I think also the base os ROCKY LINUX - 8 BASEOS repo is having the updated package . This repo is available under those VMs but still not updated with 8.8 version . Could there be a chance where this host is not properly synced with repo ?? But if thats the case also we should be able to see in sync job console for error . if we deregister and register will it help with the repo??

For a start check which repositories are enabled on the hosts which are missing the updates.

# dnf repolist -v
# dnf check-update
1 Like

I tried to use all hosts —> select the host and edit —> manage host —> edit the os tab from 8.7 to 8.8 it gave me period error for using full stop however for other machine also we followed such nomenclature only

You should never have to update the OS information manually. If it does not get updated after a reboot of the host after an upgrade, something is wrong. Perhaps remove the host from Foreman and re-register it?