Anyone successfully installed Foreman Katelo 4 ?!


Foreman installer fails with following error all the time. All pre-req and settings as per the doc,

21-05-18 04:53:06 [NOTICE] [configure] 1800 out of 1959 done.
2021-05-18 04:53:09 [ERROR ] [configure] ‘pulpcore-manager migrate --noinput’ returned 1 instead of one of [0]
2021-05-18 04:53:09 [ERROR ] [configure] /Stage[main]/Pulpcore::Database/Pulpcore::Admin[migrate --noinput]/Exec[pulpcore-manager migrate --noinput]/returns: change from ‘notrun’ to [‘0’] failed: ‘pulpcore-manager migrate --noinput’ returned 1 instead of one of [0]
2021-05-18 04:53:09 [NOTICE] [configure] 1900 out of 1959 done.

Installer never ever complete and in UI, when click on any links in Content menu it throws following error

Oops, we’re sorry but something went wrong undefined method `pulp3_repository_type_support?’ for nil:NilClass

Out of options, anyone can help ?

How to create support ticket with Foreman, its a bug , i think

Expected outcome:

Foreman and Proxy versions:

Katello 4

Foreman and Proxy plugin versions:

Distribution and version:

Other relevant data:

I guess it’s difficult to say anything, if you don’t give the exact foreman-installer command you have used, the docs you said you have followed, the OS you use, etc.

And creating multiple topics on the same issue isn’t helping either…

1 Like

foreman installer command, just used the fefault organization, location and admin username and password as parameters

Its not installing properly , all the time complaining about the error pulpcore which i pasted

This topic is not same as my previous topic, that was with DB on separate server, which I gave up , since it was not going anywhere

Thought of trying with all on one node without giving any other option other than org, loc , admin user and pwd

This basic installation is not going thru,


since i was getting pulp core migrate error i tried it manually by pointing to pulp config file and it did the migration, but still its an incomplete install and I het that message about pul03 repository ? when clicked on any menu uder contents

There is a command you have enter when you install it. Noone knows it if you don’t post it. It’s a simple copy and paste and it accurately describes the installation you have attempted… If you don’t post it we must guess and maybe or maybe not we guess right.

And again: a link to the docs you have used would be helpful to understand what you mean by “All pre-req and settings as per the doc”. Again, I can guess what docs you have used but some people are very creative finding the oddest docs at the oddest places…

And it really makes a difference on what OS you try it…

1 Like

If it’s a new installation of katello 4.0 on a new server with a new OS, there is no migration. Is it possible, that you have installed foreman or katello on that server before?

1 Like

Its a brand new install, and I tried many times spinning up new VM

foreman-installer --scenario katello \

–foreman-initial-organization “name” \

–foreman-initial-location “CA-US” \

–foreman-initial-admin-username admin \

–foreman-initial-admin-password test123

—This is the command I used

And the doc I used is

By all the setting, and pre-req I mean, storage, selinux, noexec on /tmp , ports , all as per the document

and the OS is CentOS 7

Is there a need to update the default katello.yaml and /or katello-answers.yaml, if not does it come with Pulp3 support ?, looks like from the error after installation Pulp3 repositories are not configured, do I need to do content migration /switchover ?

also all services are enabled and running

I’ve seen various pulp3 related issues on a nightly box, if you wish to run the command the say way the installer would run the pulp manager like this

sudo -u pulp PULP_SETTINGS='/etc/pulp/' DJANGO_SETTINGS_MODULE='' pulpcore-manager migrate --noinput

Perhaps it will give you more meaningful output.

Have you checked /var/log/foerman-installer/katello.log? That should have logged the error.

ok, will try that. But thats only one step in thw process, even if it goes thru , how to make remaininf steps compkete, as can be seen in errro message its stopps at arnd 1800 out 1980 or something

Also, one person suggested that if its a brand new install on a new box , (which is what i am doing) there is no migration, so why it is doing migration task, is it because of the rake migrate param, should i set to to false

the error i pasted in the problem statement is the one in katello.log as well, it dont give me any additional details… it says pulpcore migrate failed , nothing , installer says fix this issue and and run installer again

the error ether in karello.log , production.log ( after i get the famous oops something went wrong pulp3_rpository ? nil class ) do not say anything about why this error and where to look for, without this info what to fix !!!

Btw its not nightly, its 4.0

If anyone managed to install katello 4.0 (new install, not upgrade) , pl post the command , that would help, out of options as simple basic install is failing…

It’s a crucial step in setting up Pulp. If it can’t complete, the installation is only partial. It must succeed. All other steps failing after it can probably be explained by it.

I also can’t believe there’s nothing in the installer log. Without some log output or output from that command we really can’t help you.

I didnt say nothing in error log,I said logs are in katello, but it is the
same error I pasted in the beginning of the thread

I get that this step must succeed, but even after it succeed, after running
the command you pasted, what steps I should make for the installer to
continue and complete remaining steps ???

There are asditional 59 steps remaining as per the output

I did realize that there’s one fix missing in Katello 4: the working directory can matter. Bug #32309: Installing foreman from certain directories will fail on Failed to call refresh: 'pulpcore-manager collectstatic --noinput' returned 1 instead of one of [0] - Installer - Foreman. That may affect you. A fix should be in the next release that’s being prepared. I’d recommend rerunning the installer if the command pasted by @Marek_Hulan succeeded.

I see this error along with the error I pasted.
Does this mean that , Katelo 4.0 cannot be installed till the fix is released.

Which other version is stable which I can try