Auto provisioning is not working

Problem:
While doing auto provisioning after the host is discovered the VM get rebooted without going in to the bootable mode on ISO image and coming out
Expected outcome:
VM build should happen after shooting auto provisioning
Foreman and Proxy versions:
2.3
Foreman and Proxy plugin versions:
NAME Version
foreman-tasks 3.03
foreman_ansible 6.1.1
foreman_discovery 16.3.4
foreman_remote_execution 4.2.2
foreman_templates 9.0.1
katello 3.18.1

Distribution and version:
Centos 7.7
Other relevant data:
Match found for host mac0050568fa8fc (27) rule eu50apvt950 (10)
2021-03-24T18:01:39 [W|app|cad5421f] Could not find a provider for mac0050568fa8fc. Providers returned {“Katello::ManagedContentMediumProvider”=>[“Kickstart rep
ository was not set for host ‘mac0050568fa8fc’”, “Content source was not set for host ‘mac0050568fa8fc’”], “MediumProviders::Default”=>[“Operating system was no
t set for host ‘mac0050568fa8fc’”, " medium was not set for host ‘mac0050568fa8fc’", “Invalid medium ‘’ for ‘’”, “Invalid architecture ‘’ for ‘’”]}

cc @rabajaj @lzap

Hello, get your hostgroup working first, you need to test it by creating a new host with that hostgroup, give it a random MAC address and Submit. Once you get this working, then you can use auto provisioning.

Cheers.

@lzap Thanks for your prompt reply, I was able to create the host and tested with hostgroup with random VM MAC address, Even i can discover the Virtual host and when do the auto provisioning getting the below error on the provisioning logs
2021-03-29T20:38:00 [W|app|b7bf2994] Could not find a provider for mac0050568fa8fc. Providers returned {“Katello::ManagedContentMediumProvider”=>[“Kickstart rep
ository was not set for host ‘mac0050568fa8fc’”, “Content source was not set for host ‘mac0050568fa8fc’”], “MediumProviders::Default”=>[“Operating system was no
t set for host ‘mac0050568fa8fc’”, " medium was not set for host ‘mac0050568fa8fc’", “Invalid medium ‘’ for ‘’”, “Invalid architecture ‘’ for ‘’”]}
2021-03-29T20:38:00 [W|app|b7bf2994] Not queueing Host::Managed: [“Medium can’t be blank”]
2021-03-29T20:38:00 [W|app|b7bf2994] Not queueing Host::Managed: [“Medium can’t be blank”]
2021-03-29T20:38:00 [W|app|b7bf2994] Not queueing Host::Managed: [“Medium can’t be blank”]

Can you please let me know why it is not allowing to boot the image.

Thanks in advance,
Chandru.

Then taxonomy must be incorrect, check organizations and locations for all associated objects.

@lzap, Thank you,
I have checked the objects which have the same default location and organization. there is no difference in all associated object, Please let me know what exactly stopping the kickstart boot image not to boot from the console

Hi all, I solved the issue and to let everybody aware about this error I want to share my findings,

After auto provisioning you can see the kickstart file under /var/lib/tftpboot/pxelinux.cfg/ the file name will be on your mac id name(01-00:56:50:8f:a3:fc) open the file and you will see service token for kickstart file like this http://server1.example.com:8000/unattended/provision?token=1f2fe4b6-a156-4c1e-be60-03ffe077a994… just browse the url and it should work and if it doesn’t work you have not configured correctly and differs on your scenario

For me the port 8000 was not running and when I checked under foreman-installer http was false and once http module is changed to true, the auto provisioning start working with the kickstart.

@lzap Thanks for your help !!

1 Like

Yeah thanks for getting back to us. Indeed, you must not disable smart proxy HTTP port if you intend to do provisioning.