Bare metal builds

Hey there,

I have quite a few questions about bare metal builds. Ohad, could we
meet on IRC when you are available to chat about some of the questions
I have? Posting all of them here might be a little lengthy :wink:

> Hey there,
>
> I have quite a few questions about bare metal builds. Ohad, could we
> meet on IRC when you are available to chat about some of the questions
> I have? Posting all of them here might be a little lengthy :wink:
>

I'm usually available on irc, so you could try to ping me there, today would
probably be a bit harder for me, but next week for sure.
in anycase, there are other people on the channel, so you can probably get a
lot of useful info even if I'm away :wink:

in case the docs are lacking (just in case :wink: Romain has done a great job of
writing a few blogs of how to setup foreman…
checkout [1] or [2]

Ohad

[1] http://fitzdsl.net
[2]
http://translate.google.com/translate?js=n&prev=_t&hl=en&ie=UTF-8&layout=2&eotf=1&sl=fr&tl=en&u=http%3A%2F%2Ffitzdsl.netif
you need a translation).

··· On Thu, May 26, 2011 at 11:08 PM, Luke Baker wrote:


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.

Arg, I'll just post here : )

I'm having some issues getting tftp builds to work. I have set up my
smart proxy to use tftp (same box as my puppetmaster and foreman).
I've set up the tftp directories and configuration options below.

ll /tftpboot/
total 8
drwx------ 2 foreman-proxy root 4096 May 28 14:35 boot
drwx------ 2 foreman-proxy root 4096 May 28 14:37 pxelinux.cfg

ll /tftpboot/pxelinux.cfg/
total 4
-rw-rw-rw- 1 foreman-proxy foreman-proxy 161 May 28 14:37 default

(foreman-proxy/settings.yml)

Enable TFTP management

:tftp: true
:tftproot: /tftpboot

Should I leave this commented out? (foreman/settings.yml)

#:tftppath: tftp/

When I click on build in the edit view of a host, I see the following
error "Failed to enable <host> for installation:"

In the foreman/production.log I see the following item being logged,

DEPRECATION WARNING* Managing TFTP without a smart-proxy will not
be supported in the next release
TFTP Failed: Permission denied - RedHat-6.0-x86_64 or /usr/share/
foreman//01-00-18-8b-41-ce-d0

It seems odd that its trying to place the tftp file in /usr/share/
foreman?

··· On May 27, 3:50 am, Ohad Levy wrote: > On Thu, May 26, 2011 at 11:08 PM, Luke Baker wrote: > > Hey there, > > > I have quite a few questions about bare metal builds. Ohad, could we > > meet on IRC when you are available to chat about some of the questions > > I have? Posting all of them here might be a little lengthy ;) > > I'm usually available on irc, so you could try to ping me there, today would > probably be a bit harder for me, but next week for sure. > in anycase, there are other people on the channel, so you can probably get a > lot of useful info even if I'm away ;) > > in case the docs are lacking (just in case ;) Romain has done a great job of > writing a few blogs of how to setup foreman.. > checkout [1] or [2] > > Ohad > > [1]http://fitzdsl.net > [2]http://translate.google.com/translate?js=n&prev=_t&hl=en&ie=UTF-8&lay... > you need a translation). > > > > > > > > > -- > > You received this message because you are subscribed to the Google Groups > > "Foreman users" group. > > To post to this group, send email to foreman-users@googlegroups.com. > > To unsubscribe from this group, send email to > > foreman-users+unsubscribe@googlegroups.com. > > For more options, visit this group at > >http://groups.google.com/group/foreman-users?hl=en.

> Arg, I'll just post here : )
>
> I'm having some issues getting tftp builds to work. I have set up my
> smart proxy to use tftp (same box as my puppetmaster and foreman).
> I've set up the tftp directories and configuration options below.
>
> ll /tftpboot/
> total 8
> drwx------ 2 foreman-proxy root 4096 May 28 14:35 boot
> drwx------ 2 foreman-proxy root 4096 May 28 14:37 pxelinux.cfg
>
> ll /tftpboot/pxelinux.cfg/
> total 4
> -rw-rw-rw- 1 foreman-proxy foreman-proxy 161 May 28 14:37 default
>
> (foreman-proxy/settings.yml)
>
> # Enable TFTP management
> :tftp: true
> :tftproot: /tftpboot
>
> Should I leave this commented out? (foreman/settings.yml)
>
> #:tftppath: tftp/
>
> When I click on build in the edit view of a host, I see the following
> error "Failed to enable <host> for installation:"
>
> In the foreman/production.log I see the following item being logged,
>
> DEPRECATION WARNING* Managing TFTP without a smart-proxy will not
> be supported in the next release
> TFTP Failed: Permission denied - RedHat-6.0-x86_64 or /usr/share/
> foreman//01-00-18-8b-41-ce-d0
>
> You should configure which proxy to use per subnet.
then you should associate subnets with domains.
once configured, you should get a subnet drop down in the host new/edit
page.

Ohad

··· On Sat, May 28, 2011 at 10:46 PM, Luke Baker wrote:

It seems odd that its trying to place the tftp file in /usr/share/
foreman?

On May 27, 3:50 am, Ohad Levy ohadl...@gmail.com wrote:

On Thu, May 26, 2011 at 11:08 PM, Luke Baker akaba...@gmail.com wrote:

Hey there,

I have quite a few questions about bare metal builds. Ohad, could we
meet on IRC when you are available to chat about some of the questions
I have? Posting all of them here might be a little lengthy :wink:

I’m usually available on irc, so you could try to ping me there, today
would
probably be a bit harder for me, but next week for sure.
in anycase, there are other people on the channel, so you can probably
get a
lot of useful info even if I’m away :wink:

in case the docs are lacking (just in case :wink: Romain has done a great job
of
writing a few blogs of how to setup foreman…
checkout [1] or [2]

Ohad

[1]http://fitzdsl.net
[2]
http://translate.google.com/translate?js=n&prev=_t&hl=en&ie=UTF-8&lay
you need a translation).


You received this message because you are subscribed to the Google
Groups

“Foreman users” group.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To post to this group, send email to foreman-users@googlegroups.com.
To unsubscribe from this group, send email to
foreman-users+unsubscribe@googlegroups.com.
For more options, visit this group at
http://groups.google.com/group/foreman-users?hl=en.