Boot time incorrect for all hosts - never gets updated

Problem:
Under “Hosts” - “All Hosts”, the column “Boot time” displays incorrect values.
It never gets updated.
Running uptime on the host reveals a discrepancy. It is incorrect for all hosts.

Expected outcome:
With REX working correctly, “Boot time” should be correct at all times, at least after a Reboot Job has ran.

Foreman and Proxy versions:
3.5.1

Foreman and Proxy plugin versions:
foreman-tasks 7.1.1
foreman_remote_execution 8.2.0
katello 4.7.3

Distribution and version:
Foreman: Rocky Linux 8
Hosts: CentOS 7, Rocky Linux 8, Rocky Linux 9

Other relevant data:
All hosts have Tracer installed and enabled.

Boot time comes out of facts delivered by the client. REX runs jobs. It doesn’t handle facts. You’ll have to run puppet or ansible for information/facts about the clients.

1 Like

Admittedly, this server is quite new, and Foreman is new to me.
I must have missed something in the installation documentation, as the Foreman host doesn’t seem to have any facts-gathering mechanisms in place.

    1:
/var/tmp/foreman-ssh-cmd-e7f7d154-44c9-49a3-9e92-5e013f9472a7/script: line 1: puppet: command not found
   2:
Exit status: 127

Is there a way to gather facts without installing anything on remote machines?
Is there good documentation that will compare Foreman’s Puppet vs. Ansible integration, so that I can decide what’s best for me?

Thanks