Broken symlinks, unable to reupload broken RPMs

Problem:
Packages are shown in yum but are not downloadable from Foreman -> yum install xxxx ends with 404

Expected outcome:
Package gets downloaded and installed.

Foreman and Proxy versions:
1.23

Foreman and Proxy plugin versions:
defaults

Other relevant data:

I’ve uploaded 5 rpms in the same repo about a month ago and used every one of them. A month (and an upgrade to 1.23) later 3 of the 5 rpms are still listet in Foreman repo but when i try to download the packages i get 404 error. On the foreman host there are only broken symlinks regarding the 3 rpms. I tried to delete the Product (inlcuding all CV and CCVs) and checked for any occurence of the rpms on the foreman host. After they where gone I made a new product, repo and CV all with different names to the ones before and pushed the 5 rpms with the same name/version as before again. Outcome: Everything is still the same, I get 404 when I try to download one of the 3 bad rpms, broken symlinks . How can I get out of this?

All other Products are unaffected. The size of one of these RPM is about 600MB.
foreman-rake katello:upgrade_check -> returns 0 paused/dead tasks
foreman-rake katello:reimport -> successful without problems

logs

There are no suspicious logs on the foreman host.

@known1, are your repos set to the ‘on demand’ download policy? If so, try setting them to ‘immediate’, then sync and try to install content once again.

@Jonathon_Turel, sry for my late reply.
Policies are all set to immediate, I’m aware of that problem - had some trouble a few months ago with that one.
The “bad” repo which is loosing packages has no external repo configured for sync, it just gets the packages from a hammer upload.