Bug report - failed to add host

(Couldn't register to the redmine, and the password reminder never came to
my inbox)

Foreman 1.2.0 with Puppet 3.2.2:
[root@foreman ~]# rpm -qa |egrep "puppet|foreman"
foreman-release-1.2.0-1.el6.noarch
foreman-proxy-1.2.0-1.el6.noarch
foreman-1.2.0-1.el6.noarch
puppet-3.2.2-1.el6.noarch
foreman-selinux-1.2.0-1.el6.noarch
puppet-server-3.2.2-1.el6.noarch
ruby193-rubygem-foremancli-1.0-4.el6.noarch
ruby193-puppet-3.1.1-6.el6.noarch
foreman-installer-1.2.0-1.el6.noarch
foreman-postgresql-1.2.0-1.el6.noarch
puppetlabs-release-6-7.noarch

tried to add a new host (bare metal), got:
invalid value for Integer(): "0x 00"

If you feel this is an error with Foreman itself, please open a new issue
with Foreman ticketing system<Issues - Foreman>,
You would probably need to attach the Full trace<https://foreman.xiolab.lab.emc.com/hosts/new#> and
relevant log entries.
ArgumentError
invalid value for Integer(): "0x 00"
lib/net/validations.rb:43:in block in normalize_mac&#39; lib/net/validations.rb:43:inmap'
lib/net/validations.rb:43:in normalize_mac&#39; app/models/host/managed.rb:801:innormalize_addresses'
app/models/orchestration.rb:50:in valid?&#39; lib/foreman/sti.rb:26:insave_with_type'
app/controllers/hosts_controller.rb:87:in create&#39; lib/foreman/thread_session.rb:31:inclear_thread'

Hey,

my wild guess is you have a whitespace in the MAC address. Can you
check?

LZ

··· On Sun, Jul 14, 2013 at 08:22:29AM -0700, Yaniv Kaul wrote: > (Couldn't register to the redmine, and the password reminder never came to > my inbox) > > Foreman 1.2.0 with Puppet 3.2.2: > [root@foreman ~]# rpm -qa |egrep "puppet|foreman" > foreman-release-1.2.0-1.el6.noarch > foreman-proxy-1.2.0-1.el6.noarch > foreman-1.2.0-1.el6.noarch > puppet-3.2.2-1.el6.noarch > foreman-selinux-1.2.0-1.el6.noarch > puppet-server-3.2.2-1.el6.noarch > ruby193-rubygem-foremancli-1.0-4.el6.noarch > ruby193-puppet-3.1.1-6.el6.noarch > foreman-installer-1.2.0-1.el6.noarch > foreman-postgresql-1.2.0-1.el6.noarch > puppetlabs-release-6-7.noarch > > tried to add a new host (bare metal), got: > invalid value for Integer(): "0x 00" > > If you feel this is an error with Foreman itself, please open a new issue > with Foreman ticketing system, > You would probably need to attach the Full trace and > relevant log entries. > *ArgumentError* > *invalid value for Integer(): "0x 00"* > lib/net/validations.rb:43:in `block in normalize_mac' > lib/net/validations.rb:43:in `map' > lib/net/validations.rb:43:in `normalize_mac' > app/models/host/managed.rb:801:in `normalize_addresses' > app/models/orchestration.rb:50:in `valid?' > lib/foreman/sti.rb:26:in `save_with_type' > app/controllers/hosts_controller.rb:87:in `create' > lib/foreman/thread_session.rb:31:in `clear_thread' > > -- > You received this message because you are subscribed to the Google Groups "Foreman users" group. > To unsubscribe from this group and stop receiving emails from it, send an email to foreman-users+unsubscribe@googlegroups.com. > To post to this group, send email to foreman-users@googlegroups.com. > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/groups/opt_out. > >


Later,

Lukas “lzap” Zapletal
irc: lzap #theforeman

I suspect that too. I think that '<space><mac address>' causes it.

··· On Monday, July 15, 2013 12:26:08 PM UTC+3, Lukas Zapletal wrote: > > Hey, > > my wild guess is you have a whitespace in the MAC address. Can you > check? > > LZ > > On Sun, Jul 14, 2013 at 08:22:29AM -0700, Yaniv Kaul wrote: > > (Couldn't register to the redmine, and the password reminder never came > to > > my inbox) > > > > Foreman 1.2.0 with Puppet 3.2.2: > > [root@foreman ~]# rpm -qa |egrep "puppet|foreman" > > foreman-release-1.2.0-1.el6.noarch > > foreman-proxy-1.2.0-1.el6.noarch > > foreman-1.2.0-1.el6.noarch > > puppet-3.2.2-1.el6.noarch > > foreman-selinux-1.2.0-1.el6.noarch > > puppet-server-3.2.2-1.el6.noarch > > ruby193-rubygem-foremancli-1.0-4.el6.noarch > > ruby193-puppet-3.1.1-6.el6.noarch > > foreman-installer-1.2.0-1.el6.noarch > > foreman-postgresql-1.2.0-1.el6.noarch > > puppetlabs-release-6-7.noarch > > > > tried to add a new host (bare metal), got: > > invalid value for Integer(): "0x 00" > > > > If you feel this is an error with Foreman itself, please open a new > issue > > with Foreman ticketing system< > http://theforeman.org/projects/foreman/issues>, > > You would probably need to attach the Full trace< > https://foreman.xiolab.lab.emc.com/hosts/new#> and > > relevant log entries. > > *ArgumentError* > > *invalid value for Integer(): "0x 00"* > > lib/net/validations.rb:43:in `block in normalize_mac' > > lib/net/validations.rb:43:in `map' > > lib/net/validations.rb:43:in `normalize_mac' > > app/models/host/managed.rb:801:in `normalize_addresses' > > app/models/orchestration.rb:50:in `valid?' > > lib/foreman/sti.rb:26:in `save_with_type' > > app/controllers/hosts_controller.rb:87:in `create' > > lib/foreman/thread_session.rb:31:in `clear_thread' > > > > -- > > You received this message because you are subscribed to the Google > Groups "Foreman users" group. > > To unsubscribe from this group and stop receiving emails from it, send > an email to foreman-user...@googlegroups.com . > > To post to this group, send email to forema...@googlegroups.com. > > > Visit this group at http://groups.google.com/group/foreman-users. > > For more options, visit https://groups.google.com/groups/opt_out. > > > > > > -- > Later, > > Lukas "lzap" Zapletal > irc: lzap #theforeman >

> I suspect that too. I think that '<space><mac address>' causes it.

Thanks Yaniv, we saw it already at
https://bugzilla.redhat.com/show_bug.cgi?id=971012

Ohad

··· On Mon, Jul 15, 2013 at 2:00 PM, Yaniv Kaul wrote:

On Monday, July 15, 2013 12:26:08 PM UTC+3, Lukas Zapletal wrote:

Hey,

my wild guess is you have a whitespace in the MAC address. Can you
check?

LZ

On Sun, Jul 14, 2013 at 08:22:29AM -0700, Yaniv Kaul wrote:

(Couldn’t register to the redmine, and the password reminder never came
to
my inbox)

Foreman 1.2.0 with Puppet 3.2.2:
[root@foreman ~]# rpm -qa |egrep "puppet|foreman"
foreman-release-1.2.0-1.el6.**noarch
foreman-proxy-1.2.0-1.el6.**noarch
foreman-1.2.0-1.el6.noarch
puppet-3.2.2-1.el6.noarch
foreman-selinux-1.2.0-1.el6.**noarch
puppet-server-3.2.2-1.el6.**noarch
ruby193-rubygem-foremancli-1.**0-4.el6.noarch
ruby193-puppet-3.1.1-6.el6.**noarch
foreman-installer-1.2.0-1.el6.**noarch
foreman-postgresql-1.2.0-1.**el6.noarch
puppetlabs-release-6-7.noarch

tried to add a new host (bare metal), got:
invalid value for Integer(): “0x 00”

If you feel this is an error with Foreman itself, please open a new
issue
with Foreman ticketing system<http://theforeman.org/**
projects/foreman/issues http://theforeman.org/projects/foreman/issues>,

You would probably need to attach the Full trace<
https://foreman.xiolab.**lab.emc.com/hosts/new#https://foreman.xiolab.lab.emc.com/hosts/new#>
and
relevant log entries.
ArgumentError
invalid value for Integer(): "0x 00"
lib/net/validations.rb:43:in block in normalize_mac' lib/net/validations.rb:43:inmap’
lib/net/validations.rb:43:in normalize_mac' app/models/host/managed.rb:**801:innormalize_addresses’
app/models/orchestration.rb:**50:in valid?' lib/foreman/sti.rb:26:insave_with_type’
app/controllers/hosts_**controller.rb:87:in create' lib/foreman/thread_session.rb:**31:inclear_thread’


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.
Visit this group at http://groups.google.com/**group/foreman-usershttp://groups.google.com/group/foreman-users.

For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out.


Later,

Lukas “lzap” Zapletal
irc: lzap #theforeman


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.