Cannot enable Proxmox Plugin

So I just setup my Proxmox Cluster and I wanted to enable Foreman to provision systems. When I follow the guide [Provisioning Hosts] it give me an error stating: ERROR: Unrecognised option ‘–enable-foreman-plugin-proxmox’
I think I might be missing a step but I cannot seem to find any documentation on my experience.

Expected outcome:
I was expecting the plugin to install

Foreman and Proxy versions:
Both Foreman and Proxy are 3.6.1

Foreman and Proxy plugin versions:
foreman-tasks 7.2.1
foreman_ansible 11.2.0
foreman_puppet 5.1.2
foreman_remote_execution 9.1.0
katello 4.8.0

Distribution and version:
Rocky Linux 8.8

Other relevant data:
When I check Available providers I don’t see proxmox available. I must be missing something with regards to the install. I did run the dnf command to add the ForemanFogProxmox plugin as indicated on the github page but I still don’t see anything regarding proxmox

Provider Status
EC2 Not Installed
Libvirt Not Installed
OpenStack Not Installed
oVirt Not Installed
VMware Not Installed

Looking for guidance here as I am sure I am missing a step somewhere but I don’t know what it is.


Did you install the rpm?

# dnf install rubygem-foreman_fog_proxmox

I did run that command. It wasn’t showing up. After a bit of troubleshooting I decided to reboot the server and now it is showing up in the available providers:

Provider Status
EC2 Not Installed
Libvirt Not Installed
OpenStack Not Installed
oVirt Not Installed
Proxmox Installed
VMware Not Installed

However the command from the provisioning hosts documentation still doesn’t work
# foreman-installer --enable-foreman-plugin-proxmox

It doesn’t seem to be part of the foreman-installer command. I am not sure if I still need to run it however since the RPM installation may have taken care of that for me. Am I reading conflicting documentation?

Hi @thinkdez

From the docs you’ve linked above, it looks like you’ve used the documentation for Foreman “nightly” instead of “3.6”. Please have a look at Installing the Proxmox Plug-in for 3.6.


1 Like

--enable-foreman-plugin-proxmox is new in Foreman 3.7, before that you had to install the RPM manually, as you did :slight_smile:

Thanks. Yeah I got confused while trying to figure this out at 1 in the morning. Accidentally stumbled on the nightly documentation and got confused. Thanks for the guidance