Cannot import centos errata

Problem:
After following instructions to import CentOS Errata, it still isnt showing up in the content host
Expected outcome:
Content host to breakout the errata for the CentOS repos
Foreman and Proxy versions:
Foreman 2.1 Katello 3.16

After installing the suggested RPMs , I ran:
cd /opt/
git clone https://github.com/rdrgmnzs/pulp_centos_errata_import.git
cd pulp_centos_errata_import
wget -N https://cefs.steve-meier.de/errata.latest.xml.bz2
bunzip2 ./errata.latest.xml.bz2
mkdir -m0700 ~/.pulp
cat /etc/pki/katello/certs/pulp-client.crt /etc/pki/katello/private/pulp-client.key > ~/.pulp/user-cert.pem
perl ./errata_import.pl --errata=errata.latest.xml

It returned many lines of NOTICE: Skipping errata No Packages found.

I reran the command again using --include-repo flag , using the backend identifier number for the repos id, but again the same, No Packages Found.

All repos are set mirror on sync no.

I synchronize the repos like so:
hammer repository synchronize --skip-metadata-check true --product “CentOS7” --name “CentOS 7 OS” --organization “OrgName”

when I run

hammer repository info --name "CentOS 7 OS" --product "CentOS7" --organization "OrgName"
it shows:
Content Counts:
Packages: 10070
Source RPMS: 0
Package Groups: 88
Errata: 0
Module Streams: 0

All processes seem to run ok. I dont get any error messages. Can anyone suggest what I might be missing ?

Thanks

Distribution and version:

Other relevant data:

So I think the main problem is pulp-admin rpm repo list doesnt return any repos and pulp-admin repo list only returns content views.

I believe I read somewhere that the change to pulp 3 and move from mongodb to postgres is responsible for the incorrect output.

Any ideas how to get the desired output from the errata_import.pl file ? Right now its trying
@repolist = pulp-admin $pulp_args repo list -s | awk '{print \$1}' ;

See


and other answers.

Yeah , thanks, I saw that.
My reply is what brought it back to the top. I was kind of hoping to find an equivalent command to get the same info pulp admin used to provide. In the suggested post, Michael setup local repo on Foreman and injected the errata info with a proceess from https://github.com/vmfarms/generate_updateinfo.

It sure would be nice if the CentOS folks included the errata info with their packages.

I doubt RedHat would like that…