Cannot import new smart variables from one enc module


first, a quick overview about the enviroment:
puppet 3.8.1
foreman 1.9
foreman-proxy 1.9
puppet & foreman via apache 2.4/passenger 5.0.16
Puppet & Foreman server runs on Debian 8.1 with ruby 2.1.5
Note: Problem was also there at foreman 1.8 and Debian 7.

I'm trying to import our production enviroment in foreman via
enviroment->import from puppet. Foreman detects that there are changes in
the module, i'm activating the checkbox and click on update.
Problem: The new variables are not listed at Smart variables.

The first thing i've checked is the validation of the puppet environment
and the module files. Everything is OK.
I also tried to remove the complete content of the module files, just
leaving the params -> didn't worked.

For debugging i've enabled the debug logs of foreman, foreman-proxy and
puppet. Puppet & foreman-proxy didn't delivered any useful information.

In the foreman logs, i didn't found any error or something similar, but
Parameters: {"utf8"=>"✓", "authenticity_token"=>"…",

The mysterious thing is, all variables which are listed here as obsolete
are still existing in the modules. Additionally, the new variables are not
listed here.

I've checked the REST-API of foreman-proxy … here everything is working
fine, all variables will be delivered to foreman.

  • "enc_project::club::stage":{
    • "name":"club::stage",
    • "module":"enc_project",
    • "params":{
      • "ab_domain":"…",
      • "ab_mode":"master",
      • "ab_masterfqdn":"",
      • "dynatrace":false,
      • "memcache_size":1024,
      • "php_maxworkers":64,
      • "php_maxrequests":500,
      • "php_timezone":"Europe/Berlin",
      • "ab_language":"de_DE",
      • "ab_magazine":"…",
      • "ab_seomainpage":"…",
      • "nginx_htaccess":true,
      • "use_php56":false,
      • "spdy_enabled":false,
      • "hsts_enabled":false,
      • "nginx_forwarded_proto":"scheme",
      • "magazine_country":"de"


The bold marked vars are the new ones for this module.

When i'm adding variables to other modules, it works perfectly.

From this point i'm out of ideas.

Can you give me some tips how to continue debugging this problem?

Thank you very much.

Best regards,

Robert Walter