Can't convert nil into Hash at puppetlabs/apt ppas

Hey there,
i am fairly new to puppet as well as i an new to foreman. A few days ago i
ran into a problem regarding to the module puppetlabs/apt installing a ppa
with puppetlabs/apt and foreman. I tried to set ppa:marutter/rrutter as a
ppa source in class apt:ppas via foreman, which now looks like this:

override: yes
parameter type: hash
Default value: ppa:marutter/rrutter:

according to, I suppose, it
should be correct, because i also use sources with similar syntax…
But if i run
puppet agent -t --verbose
Info: Retrieving pluginfacts
Info: Retrieving plugin
Error: Could not retrieve catalog from remote server: Error 400 on SERVER:
can't convert nil into Hash at
/etc/puppet/environments/production/modules/apt/manifests/init.pp:148 on
node srv0.lab
Warning: Not using cache on failed catalog
Error: Could not retrieve catalog; skipping run

I think the "nil" output belongs to the expected, but unpresent value
behind the last colon, but I am not sure, what else I should configure
Maybe could somebody please point me to the right direction? Thanks,


Hi, I am trying manage ppa in Foreman too, but not success… How to add one or more PPAs to smart class parameters? What is correct syntax?