Can't install foreman_scap_client

Using the Red Hat rebranded version called Red Hat Satellite to run Openscap scans. The scans fail due to inability to install the foreman_scap_client dependency on older version of ncurses. I’m not sure if this due to Foreman or OpenSCAP using ncurses.

[root@localhost bha]# yum info rubygem-foreman_scap_client
Loaded plugins: product-id, search-disabled-repos, subscription-manager
Available Packages
Name : rubygem-foreman_scap_client
Arch : noarch
Version : 0.4.6
Release : 1.el7sat
Size : 22 k
Repo : rhel-7-server-satellite-tools-6.7-rpms/x86_64
Summary : Client script that runs OpenSCAP scan and uploads the result
to foreman proxy
License : GPLv3
Description : Client script that runs OpenSCAP scan and uploads the result
to foreman proxy.

—> Package pcre.i686 0:8.32-12.el7 will be installed
–> Finished Dependency Resolution
–> Finding unneeded leftover dependencies
Found and removing 0 unneeded dependencies
Error: Package: ncurses-libs-5.9-13.20130511.el7.i686 (rhel-7-server-rpms)
Requires: ncurses-base = 5.9-13.20130511.el7
Installed: ncurses-base-5.9-14.20130511.el7_4.noarch
ncurses-base = 5.9-14.20130511.el7_4
Available: ncurses-base-5.9-13.20130511.el7.noarch
ncurses-base = 5.9-13.20130511.el7
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

Created Github issue @

Thank you for reporting this, I’ll take a look. Though if you are using Satellite that means you are a Red Hat customer and I would recommend reporting any problems with Satellite to RH via appropriate channels.

also I’m nearly sure, foreman_scap_client doesn’t depend on ncurses, based on the log, this may be a problem of server-satellite-tools

@Ondrej_Prazak @Marek_Hulan Thanks… I’m pretty sure it is. But, I just need the sources to confirm since they’ll pull the finger-pointing game. In short, they’re not up-to-date on the foreman_scap_client package.

foreman_scap_client does not depend on ncurses, this seems like some sort of a package clash. From the output is seems there is ncurses-base-5.9-14.20130511.el7_4.noarch package installed but ncurses-lib requires ncurses-base-5.9-13.20130511.el7.noarch. It might be useful finding out what uses the installed package and if it can be removed.

I think it might be due to Red Hat being out-of-date on their Satellite/Foreman software. I think it’s the only thing that would explain why a newer version of ncurses won’t work.