Centos 8 product RPMs not being added to the centos 8 content view

We are trying to add centos 8 for provisioning. We have added the product and content view as described in this document: https://computingforgeeks.com/sync-centos-8-repositories-on-satellite-katello-foreman/

Expected outcome:
We found that when we tried to provision a box several rpms were missing that our kickstart had listed. These rpms are available in the appstream “Product”, but not available in the “Content View” We expect to see the same rpms available in the content view that are available in the product. For example, these should show the same rpms:

ls /var/lib/pulp/published/yum/https/repos/carfax/Library/custom/centos_8/centos_8_appstream/Packages/ | grep ^x

ls /var/lib/pulp/published/yum/https/repos/carfax/Library/custom/centos_8/centos_8_appstream/Packages/ | grep ^x

Foreman and Proxy versions:

Foreman and Proxy plugin versions:
foreman-tasks 0.17.5
foreman_chef 0.9.0
foreman_discovery 16.0.1
foreman_docker 5.0.0
foreman_remote_execution 2.0.6
katello 3.14.0

Distribution and version:

Other relevant data:
We have deleted the content view and product, and tried multiple times to recreate them, but every time we publish the content view, rpms are missing in the directory of the content view. The package number list on the GUI indicates that the rpms should be there.

I had a copy error. That example should have looked like this:

ls /var/lib/pulp/published/yum/https/repos/carfax/Library/carfax_centos_8_cv/custom/centos_8/centos_8_appstream/Packages/ | grep ^x

ls /var/lib/pulp/published/yum/https/repos/carfax/Library/custom/centos_8/centos_8_appstream/Packages/ | grep ^x

I found the solution here: Need help wih CentOs 8 content view

1 Like