Cloud-init needs python3-jsonschema-2.6.0-4.el8.noarch but foreman needs python38-jsonschema-3.2.0-7.el8.noarch

CentOS 8 Stream, Foreman 3.2 / Katello 4.4

If I have cloud-init installed, the foreman-installer with install the newer jsonschema.

However, one cannot run yum update anymore, due to this conflict.

Last metadata expiration check: 0:36:44 ago on Wed 13 Apr 2022 02:29:32 PM CEST.
 Problem: cannot install both python38-jsonschema-3.2.0-6.el8.noarch and python38-jsonschema-3.2.0-7.el8.noarch
  - cannot install the best update candidate for package python38-jsonschema-3.2.0-7.el8.noarch
  - cannot install the best update candidate for package python3-jsonschema-2.6.0-4.el8.noarch
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

I need to de-install cloud-init, then run yum update and then re-install cloud-init, which installs python3-jsonschema-2.6.0-4.el8.noarch with no problems.

I’m not really complaining, but this sort-of makes it a bit more difficult to run a Foreman or a Smart-Proxy in OpenStack.

Hey, this should work (at least we tried to make it work in Remove python 3.6 package obsolete and exclude files in bin directory by simaishi · Pull Request #325 · theforeman/pulpcore-packaging · GitHub)

Do you have the full error message causing this?

Oooh, I think I know what’s happening there.

You should be able to workaround this by using dnf install python3-jsonschema-2.6.0-4.el8.noarch python38-jsonschema-3.2.0-7.el8.noarch or explicitly adding exclude=python38-jsonschema-3.2.0-6.el8.noarch to the repo file that defines the pulpcore repo.

I’ll see that we fix the repo properly tomorrow

1 Like

Repo is fixed, enjoy!

Sorry, I was away.

I will try soon.