[ContentMigration] switchover fails after successful prepare

As I have now ran into the second issue, which only appears during the switchover, I wonder if the way it is handled right now is really good:

The prepare tries to migrate everything.

The switchover runs another prepare and but then may still fail, because for something is still missing, e.g.

ERROR: yum repositories with ID [40286,40803,40105,40504,40673,30638,28594] have a NULL value for version_href


ERROR: at least one Erratum record has migrated_pulp3_href NULL value

I wonder, why these kind of checks don’t happen at the end of the prepare. That would be helpful.

It would also helpful, if it would not stop after the first issue found. In the beginning I had first error above. After I worked around that issue, I got the next error. I wonder what might come after that. Thus, if it show both or all errors you could try to solve them all in one iteration and not one after another.

I also find the message troublesome:

Switching specified content over to pulp 3                            [FAIL]
Failed executing foreman-rake katello:pulp3_content_switchover, exit status 1:
 ERROR: at least one Erratum record has migrated_pulp3_href NULL value
Scenario [Switch support for certain content from Pulp 2 to Pulp 3] failed.

So does that mean, that after I have successfully worked around the issue with the yum repositories, those have actually switched over to pulp3 while the errata (and whatever might be switched after the errata) are still on pulp2? I expected the switchover to be a all or nothing, i.e. use either use pulp2 or pulp3 for everything and not a mix of both…