Custom-repo installer options change, 1.21

Running a working in the past installation script. Received Unrecognised option errors for:

We’re running on an air-gapped network with our own repository copies.

Expected outcome:
Use local configured repositories

Foreman and Proxy versions:
1.21 (as of Friday, 12 April 2019)

Foreman and Proxy plugin versions:

Other relevant data:
foreman-installer --full-help no longer lists the *custom-repo options
I’ve set configure-epel-repositories and configure-scl-repositories to false, installation is proceeding so far

The installer has always defaulted to not managing these repositories, but in 1.21 this functionality was merged into a single parameter. We should have a migration in place to automatically do this for you and you shouldn’t have noticed anything. Did you see that it was attempting to manage these?

No, the installer gave the “Unrecognised option” error and exited. I commented out the lines and continued. I’ve restarted the install for some other errors. What’s the new, merged, single parameter?

We used to have --foreman-custom-repo boolean (and a similar one in the proxy). There was also --foreman-repo version. We’ve dropped the default from the repo which means we no longer need a separate parameter to disable repo management. Since --foreman-custom-repo and foreman-proxy-custom-repo have always defaulted to true, I didn’t think people actually used them so I haven’t made an explicit note about this in the release notes.

After commenting out the options, the installer completes. However, I now get “no smart proxy server found” from hammer ... host update (for the puppet master) fails.
“Interfaces.subnet is not defined for host’s location” (or organization)

We have a long set of hammer commands (in our local install script) that completed successfully; only this update is reporting error. However, the kickstart files that should be added did not seem available when I looked with the GUI.

The *custom-repo option changes may be a red herring, but that’s the only thing that’s changed in scripts that worked with 1.20 with no problem.

I also have a Failed to open TCP connection to in the production log. Since this is on an air-gapped, standalone network, it will never get to How do I prevent it from trying?

I think the *custom-repo options prevented that. What installer options should I set, or should I revert to 1.20 (since 1.21 isn’t installing for us)?