Debian local repo sync issues

Install Debian(stretch) using foreman from local katello repo doesn’t work
Expected outcome:
Install Debian(stretch) using foreman from local katello repo
Foreman and Proxy versions:
Foreman and Proxy plugin versions:
Katello 3.12.3
Distribution and version:
Debian Stretch
Other relevant data:
Trying to get the PXE Installation of debian Stretch using a local Katello Repo in Foreman working i stumbled about the following problems:

  1. Release File in debian/dists/stretch/main/binary-amd64/ missing
  2. debian/dists/stretch/main/Release.gpg missing
  3. Release File in debian/dists/stretch/main doesn’t have the correct signature and is not the original one from
  4. debian/dists/stretch/main/debian-installer directory completely missing
  5. directory structure under pool/main/ missing. all packages are directly in this directy


  1. after loading debian/dists/stretch/main/Release during PXE Install the file debian/dists/stretch/main/binary-amd64/Release is requested. i could download this file and found the right place to manually put it in and make it available
  2. after working through 1. the installer fails to check debian/dists/stretch/main/Release because debian/dists/stretch/main/Release.gpg is missing. once again downloading and putting in the correct directory solved the problem
  3. after 2. the installer downloads debian/dists/stretch/main/Release.gpg and the check of debian/dists/stretch/main/Release fails again, because the Release file in Foreman is different than the on manually putting the correct file solved the problem.
  4. after getting through the GPG Check of the Release file the installer comlains about missing the debian/dists/stretch/main/debian-installer directory and its contents. once again manually download solved the problem.
  5. this time i’m stuck, because i cant change the whole directory structure in pool/main/. on under this directory the packages are in detailed structure. in foreman its a flat structure, where all packages are directly in pool/main/, but installer is looking for the detailed structure.

Has anyone gotten a debian PXE from a local Debian Repo working ? If yes, how ?
Did i miss someting ?
Installation using as installation source works fine.
Regarding the local repo, i created one and used as source. i successfully synced it and configured it as installation media for the to be installed host.


Hey, I’ve renamed the title to it catches eyes of folks who maintain debian sync plugins. @Bernhard_Suttner

Installation of a debian / ubuntu host using the related katello repository (content view or library content) is not implemented right now (and wont’t be in future with pulp 2).