DHCPD / need to remove "supersede" before "server.next-server" in order to boot TFTP

Hello. when I “build” a host, I need to remove then after the
supersede word from the dhcp.lease file and restart the dhcpd daemon.
If not, the TFTP client does not load the file “…”

Expected outcome:

Foreman and Proxy versions:
Foreman and Proxy plugin versions:

Distribution and version:
RHEL 8.3
Other relevant data:

Thank you for your advise.


why do you need to do again? Why woud any change in dhcpd.conf affect TFTP server? Our installer deploys all necessary PXE files into the TFTP directory. If you have deployed some things on undstandard paths, use relative symlinks to workaround that. Important: must be relative because TFTP runs in a chroot.

I had to make some changed in order to work before I finally add another option the installer
And then it worked. Not sure at all why this parameter was mandatory.

If you do not set this value, Foreman will use TFTP Smart Proxy hostname as the TFTP file entry. ISC DHCP allows that.

What’s weird is that when I don’t put the IP address then the resolution name doesn’t work unless I remove the word supersede

That keyword actually makes the setting effective. Without it, the statement is ignored and the default value is used.