Disable SSL in favor of SSH for provisioning

Unable to upload facts due to SSL failures in test environment
Expected outcome:
Successfully upload facts
Foreman and Proxy versions:
Foreman and Proxy plugin versions:
18.0.5 discovery service
Distribution and version:

Feb 02 20:08:37 fdi /usr/bin/discovery-register[2248]: Registering host at (http://XXX.XXX.net)
Feb 02 20:10:13 fdi /usr/bin/discovery-register[2248]: Could not send facts to server: getaddrinfo: Name or service not known
Fact cache invalid, reloading to foreman
Feb 02 20:56:54 fdi /usr/bin/discovery-register[6785]: Discovered by URL: http://XXX.XXX.net
Feb 02 20:56:54 fdi /usr/bin/discovery-register[6785]: Registering host at (http://XXX.XXX.net)
Feb 02 20:58:12 fdi /usr/bin/discovery-register[6785]: Response from server 301: <html><body>You are being <a href="https://XXX.XXX.net/api/v2/discovered_hosts/facts">redirected</a>.</body></html>
Feb 02 20:58:12 fdi /usr/bin/discovery-register[6785]: Wrote result 301 to /tmp/discovery-http-failure

Other relevant data:

This is a test environment and I don’t want to have to configure SSL to do testing, how can I drop SSL and use SSH like mentioned in Foreman discovery IP?

Check your pxelinux_discovery provisioning template snippet, it uses (by default) the macro foreman_server_url. The documentation for this macro says “Returns the server URL based on global setting foreman_url”. So changing this setting should do the trick.