Dynflow/foreman-tasks merged into Katello master

Hi,

I've just merged the dynflow branch into Katello master.

https://github.com/Katello/katello/pull/3550

When in development, bundle install should do the trick (no external process
needs to be run). The builds/installer were also updated to work properly in production.

I had to update the dynflow to 0.5.0 from 0.1.0, so you might have seen
some issues with the dynflow 0.1.0 not being available in koji when building:
this should disappear next time the build is done.

Let me know if having any issues. I hope I've not broke something or will able
to fix soon.

– Ivan

awesome work, looks good in dev mode from a git checkout.

working on a few things to clean up in the nightly RPM based install:

  • ruby193-rubygem-foreman-tasks was stuck at 0.1, jmontleon untagged
    that build and we are now up at 0.3
  • katello-jobs init script seems to be stuck waiting for the service
    to start which causes the katello-installer to fail that step

Mike

··· On 02/25/2014 09:22 AM, Ivan Necas wrote: > Hi, > > I've just merged the dynflow branch into Katello master. > > https://github.com/Katello/katello/pull/3550 > > When in development, `bundle install` should do the trick (no external process > needs to be run). The builds/installer were also updated to work properly in production. > > I had to update the dynflow to 0.5.0 from 0.1.0, so you might have seen > some issues with the dynflow 0.1.0 not being available in koji when building: > this should disappear next time the build is done. > > Let me know if having any issues. I hope I've not broke something or will able > to fix soon. > > -- Ivan > -- Mike McCune mmccune AT redhat.com Red Hat Engineering | Portland, OR Systems Management | 650-254-4248

I was able to do a clean install and it worked for me.

  • bk
··· On 02/25/2014 12:22 PM, Ivan Necas wrote: > Hi, > > I've just merged the dynflow branch into Katello master. > > https://github.com/Katello/katello/pull/3550 > > When in development, `bundle install` should do the trick (no external process > needs to be run). The builds/installer were also updated to work properly in production. > > I had to update the dynflow to 0.5.0 from 0.1.0, so you might have seen > some issues with the dynflow 0.1.0 not being available in koji when building: > this should disappear next time the build is done. > > Let me know if having any issues. I hope I've not broke something or will able > to fix soon. > > -- Ivan >

Nice job!

– bk

··· On 02/25/2014 12:22 PM, Ivan Necas wrote: > Hi, > > I've just merged the dynflow branch into Katello master. > > https://github.com/Katello/katello/pull/3550 > > When in development, `bundle install` should do the trick (no external process > needs to be run). The builds/installer were also updated to work properly in production. > > I had to update the dynflow to 0.5.0 from 0.1.0, so you might have seen > some issues with the dynflow 0.1.0 not being available in koji when building: > this should disappear next time the build is done. > > Let me know if having any issues. I hope I've not broke something or will able > to fix soon. > > -- Ivan >

UPDATE: katello's nightly installs and configures cleanly without any
modifications necessary.

Did a quick smoke test:

  • Login to the webui
  • I imported a manifest, enabled some repos
  • synced repos
  • the Monitor -> Tasks page came up with some of the things that I did

all worked well. Will do a bit more testing

Mike

··· On 02/25/2014 01:36 PM, Mike McCune wrote: > On 02/25/2014 09:22 AM, Ivan Necas wrote: >> Hi, >> >> I've just merged the dynflow branch into Katello master. >> >> https://github.com/Katello/katello/pull/3550 >> >> When in development, `bundle install` should do the trick (no external >> process >> needs to be run). The builds/installer were also updated to work >> properly in production. >> >> I had to update the dynflow to 0.5.0 from 0.1.0, so you might have seen >> some issues with the dynflow 0.1.0 not being available in koji when >> building: >> this should disappear next time the build is done. >> >> Let me know if having any issues. I hope I've not broke something or >> will able >> to fix soon. >> >> -- Ivan >> > awesome work, looks good in dev mode from a git checkout. > > working on a few things to clean up in the nightly RPM based install: > > * ruby193-rubygem-foreman-tasks was stuck at 0.1, jmontleon untagged > that build and we are now up at 0.3 > * katello-jobs init script seems to be stuck waiting for the service > to start which causes the katello-installer to fail that step > > Mike

We're getting errors intermittently in the UI and consistently in the rails console (when doing "reload!").

I glanced at the code but did not see an immediate solution.

David

··· ----- Original Message ----- > From: "Mike McCune" > To: foreman-dev@googlegroups.com > Sent: Tuesday, February 25, 2014 7:11:26 PM > Subject: Re: [foreman-dev] Dynflow/foreman-tasks merged into Katello master > > On 02/25/2014 01:36 PM, Mike McCune wrote: > > On 02/25/2014 09:22 AM, Ivan Necas wrote: > >> Hi, > >> > >> I've just merged the dynflow branch into Katello master. > >> > >> https://github.com/Katello/katello/pull/3550 > >> > >> When in development, `bundle install` should do the trick (no external > >> process > >> needs to be run). The builds/installer were also updated to work > >> properly in production. > >> > >> I had to update the dynflow to 0.5.0 from 0.1.0, so you might have seen > >> some issues with the dynflow 0.1.0 not being available in koji when > >> building: > >> this should disappear next time the build is done. > >> > >> Let me know if having any issues. I hope I've not broke something or > >> will able > >> to fix soon. > >> > >> -- Ivan > >> > > awesome work, looks good in dev mode from a git checkout. > > > > working on a few things to clean up in the nightly RPM based install: > > > > * ruby193-rubygem-foreman-tasks was stuck at 0.1, jmontleon untagged > > that build and we are now up at 0.3 > > * katello-jobs init script seems to be stuck waiting for the service > > to start which causes the katello-installer to fail that step > > > > Mike > > UPDATE: katello's nightly installs and configures cleanly without any > modifications necessary. > > Did a quick smoke test: > > * Login to the webui > * I imported a manifest, enabled some repos > * synced repos > * the Monitor -> Tasks page came up with some of the things that I did > > all worked well. Will do a bit more testing > > Mike > > -- > You received this message because you are subscribed to the Google Groups > "foreman-dev" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to foreman-dev+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/groups/opt_out. >

I am seeing

http://fpaste.org/80598/13934320/

– bk

··· On 02/26/2014 11:28 AM, David Davis wrote: > We're getting errors intermittently in the UI and consistently in the rails console (when doing "reload!"). > > https://gist.github.com/daviddavis/e8d1b29524bd67f0d2e2 > > I glanced at the code but did not see an immediate solution. > > David > > ----- Original Message ----- > > From: "Mike McCune" > > To: foreman-dev@googlegroups.com > > Sent: Tuesday, February 25, 2014 7:11:26 PM > > Subject: Re: [foreman-dev] Dynflow/foreman-tasks merged into Katello master > > > > On 02/25/2014 01:36 PM, Mike McCune wrote: > > > On 02/25/2014 09:22 AM, Ivan Necas wrote: > > >> Hi, > > >> > > >> I've just merged the dynflow branch into Katello master. > > >> > > >> https://github.com/Katello/katello/pull/3550 > > >> > > >> When in development, `bundle install` should do the trick (no external > > >> process > > >> needs to be run). The builds/installer were also updated to work > > >> properly in production. > > >> > > >> I had to update the dynflow to 0.5.0 from 0.1.0, so you might have seen > > >> some issues with the dynflow 0.1.0 not being available in koji when > > >> building: > > >> this should disappear next time the build is done. > > >> > > >> Let me know if having any issues. I hope I've not broke something or > > >> will able > > >> to fix soon. > > >> > > >> -- Ivan > > >> > > > awesome work, looks good in dev mode from a git checkout. > > > > > > working on a few things to clean up in the nightly RPM based install: > > > > > > * ruby193-rubygem-foreman-tasks was stuck at 0.1, jmontleon untagged > > > that build and we are now up at 0.3 > > > * katello-jobs init script seems to be stuck waiting for the service > > > to start which causes the katello-installer to fail that step > > > > > > Mike > > > > UPDATE: katello's nightly installs and configures cleanly without any > > modifications necessary. > > > > Did a quick smoke test: > > > > * Login to the webui > > * I imported a manifest, enabled some repos > > * synced repos > > * the Monitor -> Tasks page came up with some of the things that I did > > > > all worked well. Will do a bit more testing > > > > Mike > > > > -- > > You received this message because you are subscribed to the Google Groups > > "foreman-dev" group. > > To unsubscribe from this group and stop receiving emails from it, send an > > email to foreman-dev+unsubscribe@googlegroups.com. > > For more options, visit https://groups.google.com/groups/opt_out. > > >

> We're getting errors intermittently in the UI and consistently in the rails console (when doing "reload!").
>
> https://gist.github.com/daviddavis/e8d1b29524bd67f0d2e2
>
> I glanced at the code but did not see an immediate solution.

this was just an issue in the cv-rework branch. fixed here:
https://github.com/Katello/katello/pull/3741

··· On 02/26/2014 11:28 AM, David Davis wrote: > > David > > ----- Original Message ----- > > From: "Mike McCune" > > To: foreman-dev@googlegroups.com > > Sent: Tuesday, February 25, 2014 7:11:26 PM > > Subject: Re: [foreman-dev] Dynflow/foreman-tasks merged into Katello master > > > > On 02/25/2014 01:36 PM, Mike McCune wrote: > > > On 02/25/2014 09:22 AM, Ivan Necas wrote: > > >> Hi, > > >> > > >> I've just merged the dynflow branch into Katello master. > > >> > > >> https://github.com/Katello/katello/pull/3550 > > >> > > >> When in development, `bundle install` should do the trick (no external > > >> process > > >> needs to be run). The builds/installer were also updated to work > > >> properly in production. > > >> > > >> I had to update the dynflow to 0.5.0 from 0.1.0, so you might have seen > > >> some issues with the dynflow 0.1.0 not being available in koji when > > >> building: > > >> this should disappear next time the build is done. > > >> > > >> Let me know if having any issues. I hope I've not broke something or > > >> will able > > >> to fix soon. > > >> > > >> -- Ivan > > >> > > > awesome work, looks good in dev mode from a git checkout. > > > > > > working on a few things to clean up in the nightly RPM based install: > > > > > > * ruby193-rubygem-foreman-tasks was stuck at 0.1, jmontleon untagged > > > that build and we are now up at 0.3 > > > * katello-jobs init script seems to be stuck waiting for the service > > > to start which causes the katello-installer to fail that step > > > > > > Mike > > > > UPDATE: katello's nightly installs and configures cleanly without any > > modifications necessary. > > > > Did a quick smoke test: > > > > * Login to the webui > > * I imported a manifest, enabled some repos > > * synced repos > > * the Monitor -> Tasks page came up with some of the things that I did > > > > all worked well. Will do a bit more testing > > > > Mike > > > > -- > > You received this message because you are subscribed to the Google Groups > > "foreman-dev" group. > > To unsubscribe from this group and stop receiving emails from it, send an > > email to foreman-dev+unsubscribe@googlegroups.com. > > For more options, visit https://groups.google.com/groups/opt_out. > > >

I'm hitting this too.

David

··· ----- Original Message ----- > From: "Bryan Kearney" > To: foreman-dev@googlegroups.com > Sent: Wednesday, February 26, 2014 11:29:15 AM > Subject: Re: [foreman-dev] Dynflow/foreman-tasks merged into Katello master > > I am seeing > > http://fpaste.org/80598/13934320/ > > -- bk > > On 02/26/2014 11:28 AM, David Davis wrote: > > We're getting errors intermittently in the UI and consistently in the rails > > console (when doing "reload!"). > > > > https://gist.github.com/daviddavis/e8d1b29524bd67f0d2e2 > > > > I glanced at the code but did not see an immediate solution. > > > > David > > > > ----- Original Message ----- > > > From: "Mike McCune" > > > To: foreman-dev@googlegroups.com > > > Sent: Tuesday, February 25, 2014 7:11:26 PM > > > Subject: Re: [foreman-dev] Dynflow/foreman-tasks merged into Katello > > > master > > > > > > On 02/25/2014 01:36 PM, Mike McCune wrote: > > > > On 02/25/2014 09:22 AM, Ivan Necas wrote: > > > >> Hi, > > > >> > > > >> I've just merged the dynflow branch into Katello master. > > > >> > > > >> https://github.com/Katello/katello/pull/3550 > > > >> > > > >> When in development, `bundle install` should do the trick (no external > > > >> process > > > >> needs to be run). The builds/installer were also updated to work > > > >> properly in production. > > > >> > > > >> I had to update the dynflow to 0.5.0 from 0.1.0, so you might have > > > >> seen > > > >> some issues with the dynflow 0.1.0 not being available in koji when > > > >> building: > > > >> this should disappear next time the build is done. > > > >> > > > >> Let me know if having any issues. I hope I've not broke something or > > > >> will able > > > >> to fix soon. > > > >> > > > >> -- Ivan > > > >> > > > > awesome work, looks good in dev mode from a git checkout. > > > > > > > > working on a few things to clean up in the nightly RPM based install: > > > > > > > > * ruby193-rubygem-foreman-tasks was stuck at 0.1, jmontleon untagged > > > > that build and we are now up at 0.3 > > > > * katello-jobs init script seems to be stuck waiting for the service > > > > to start which causes the katello-installer to fail that step > > > > > > > > Mike > > > > > > UPDATE: katello's nightly installs and configures cleanly without any > > > modifications necessary. > > > > > > Did a quick smoke test: > > > > > > * Login to the webui > > > * I imported a manifest, enabled some repos > > > * synced repos > > > * the Monitor -> Tasks page came up with some of the things that I did > > > > > > all worked well. Will do a bit more testing > > > > > > Mike > > > > > > -- > > > You received this message because you are subscribed to the Google Groups > > > "foreman-dev" group. > > > To unsubscribe from this group and stop receiving emails from it, send an > > > email to foreman-dev+unsubscribe@googlegroups.com. > > > For more options, visit https://groups.google.com/groups/opt_out. > > > > > > > -- > You received this message because you are subscribed to the Google Groups > "foreman-dev" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to foreman-dev+unsubscribe@googlegroups.com. > For more options, visit https://groups.google.com/groups/opt_out. >

> I am seeing
>
> http://fpaste.org/80598/13934320/

This usually happens, when you have no org selected when going to the Katello universe

– Ivan

··· ----- Original Message -----

– bk

On 02/26/2014 11:28 AM, David Davis wrote:

We’re getting errors intermittently in the UI and consistently in the rails
console (when doing “reload!”).

https://gist.github.com/daviddavis/e8d1b29524bd67f0d2e2

I glanced at the code but did not see an immediate solution.

David

----- Original Message -----

From: “Mike McCune” mmccune@redhat.com
To: foreman-dev@googlegroups.com
Sent: Tuesday, February 25, 2014 7:11:26 PM
Subject: Re: [foreman-dev] Dynflow/foreman-tasks merged into Katello
master

On 02/25/2014 01:36 PM, Mike McCune wrote:

On 02/25/2014 09:22 AM, Ivan Necas wrote:

Hi,

I’ve just merged the dynflow branch into Katello master.

https://github.com/Katello/katello/pull/3550

When in development, bundle install should do the trick (no external
process
needs to be run). The builds/installer were also updated to work
properly in production.

I had to update the dynflow to 0.5.0 from 0.1.0, so you might have
seen
some issues with the dynflow 0.1.0 not being available in koji when
building:
this should disappear next time the build is done.

Let me know if having any issues. I hope I’ve not broke something or
will able
to fix soon.

– Ivan

awesome work, looks good in dev mode from a git checkout.

working on a few things to clean up in the nightly RPM based install:

  • ruby193-rubygem-foreman-tasks was stuck at 0.1, jmontleon untagged
    that build and we are now up at 0.3
  • katello-jobs init script seems to be stuck waiting for the service
    to start which causes the katello-installer to fail that step

Mike

UPDATE: katello’s nightly installs and configures cleanly without any
modifications necessary.

Did a quick smoke test:

  • Login to the webui
  • I imported a manifest, enabled some repos
  • synced repos
  • the Monitor -> Tasks page came up with some of the things that I did

all worked well. Will do a bit more testing

Mike


You received this message because you are subscribed to the Google Groups
"foreman-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


You received this message because you are subscribed to the Google Groups
"foreman-dev" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-dev+unsubscribe@googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.