Dynflow port 8008 not open


#1

Problem:
on my fresh installation foreman 1.21 dynflow port not open.
I have ubuntu 16.04

i installed like described in the docomentation:

DEB:
apt-get install ruby-foreman-remote-execution
ruby-smart-proxy-remote-execution-ssh

The next thing to do is make sure the Smart Proxy, Smart Proxy
Dynflow Core and Foreman can talk to each other. If you’re on Debian,
there’s no need to do anything. This is done by properly configuring :core_url
in /etc/foreman-proxy/settings.d/dynflow.yml and :foreman_url , :listen
and :port keys in /etc/smart_proxy_dynflow_core/settings.yml .

Why i dont have the folder /etc/smart_proxy_dynflow_core/settings.yml ?

Expected outcome:
Dynflow port 8008 opened

Foreman and Proxy versions: Foreman and Proxy plugin versions:

ii  foreman                                                     1.21.0-1                                   amd64        Systems management web interface
ii  foreman-cli                                                 1.21.0-1                                   all          metapackage providing hammer CLI for Foreman
ii  foreman-debug                                               1.21.0-1                                   all          provides support utility foreman-debug.
ii  foreman-installer                                           1.21.0-1                                   all          Automated puppet-based installer for The Foreman
ii  foreman-postgresql                                          1.21.0-1                                   all          metapackage providing PostgreSQL dependencies for Foreman
ii  foreman-proxy                                               1.21.0-1                                   all          RESTful proxies for DNS, DHCP, TFTP, and Puppet
ii  ruby-foreman-ansible                                        2.3.2-1                                    all          Foreman Ansible plugin
ii  ruby-foreman-ansible-core                                   2.2.0-1                                    all          Foreman ansible - core bits
ii  ruby-foreman-deface                                         1.3.2-1                                    all          Foreman Deface Plugin Dependency
ii  ruby-foreman-remote-execution                               1.7.0-1                                    all          Foreman Remote Execution Plugin
ii  ruby-foreman-remote-execution-core                          1.1.3-1                                    all          Foreman remote execution - core bits
ii  ruby-foreman-tasks                                          0.14.5-1                                   all          Tasks management engine for Foreman.
ii  ruby-foreman-tasks-core                                     0.2.5-1                                    all          Foreman tasks - core bits
ii  ruby-hammer-cli-foreman                                     0.16.0-1                                   all          Foreman commands for Hammer


ii  ruby-smart-proxy-ansible                                    2.1.2-1                                    all          Ansible support for Foreman smart proxy
ii  ruby-smart-proxy-dynflow                                    0.2.2-1                                    all          Dynflow runtime for Foreman smart proxy
ii  ruby-smart-proxy-dynflow-core                               0.2.2-1                                    all          Dynflow runtime for Foreman smart proxy
ii  ruby-smart-proxy-remote-execution-ssh                       0.2.0-2                                    all          SSH remote execution provider for Foreman smart proxy

Did anyone know what i make wrong ?

Best regards
mobios


#2

The file /etc/foreman-proxy/settings.d/dynflow.yml looks like


:enabled: true
:database: /var/lib/foreman-proxy/dynflow/dynflow.sqlite
:core_url: ‘http://127.0.0.1:8008

Foreman, foreman-proxy and ansible all on one host. No host firewall.
Importing ansible roles in foreman OK.
Importing ansible variables in foreman OK.
Execute roles from foreman not OK.


#3

On Debian and derivatives Dynflow core runs inside the smart proxy, so the port 8008 doesn’t need to be opened.

If you’re on Debian, there’s no need to do anything.

^ That’s why that part is there.

Could you elaborate on this?


#4

If i execute ansible roles:

error: 1:
ERROR! No setting was provided for required configuration plugin_type: callback plugin: foreman setting: url

Playbooks ansible-command ist all OK. Just ansible roles i cant execute.


#5

Tommorow i can provide log files.


#6

Thanks now all OK. How aruzicka said with ubuntu dynflow port not needed.