ENC and reports only work with login disabled

Foreman 1.1 authorises access to the ENC interface to hosts that have
smart proxies installed with the puppet feature (i.e. they're

If you have a smart proxy installed on the puppetmaster, check it's
added into Foreman and then read the Foreman log file
(/var/log/foreman/production.log) when an ENC request is made, as it
will log a message while rejecting the request. The hostname will need
to match and the log should indicate if it doesn't.

If you don't have a smart proxy (which you will want for class imports)
then you can disable the authorisation entirely, but this isn't recommended:

(see no security: disable auth).

··· On 08/02/13 17:39, Marc Cirauqui wrote: > Hello all, > > I been setiing up a puppet master and foreman all in one box. It is > everything working ok if I deactivate logins. ENC works, and reports work. > > The problem comes when enabling login, reports and ENC stop working. As > per ENC script output (foreman default one). > > It is running on CentOS 6, puppet 3.1, foreman 1.1stable. > > I'm shure i am missing something trivial, but I wasn't able to find it > on google... ny help?

Dominic Cleal
Red Hat Engineering

Hum… I see.

That makes sense as I don't have DNS records yet. Will try when those are set up.

Thanks a lot!