Environments not working! Please help

Hi all!,

I just updated to Foreman 1.7.2 and since then my puppet agents are picking
up "wrong" environments :confused:

running on the client I get

root@unstable:~# puppet agent --configprint environment
production

however the client is set to "development" in Foremanā€¦

Any clue?

Best Regards
Siggi

I believe that configprint just echoes the environment given in
/etc/puppet/puppet.conf. If foreman is sending a different environment,
puppet should print a warning at the beginning of the puppet run, and use
the environment given by foreman instead. I recommend adding a rule to
update puppet.conf with the current environment. You can check the yaml
output of foreman to see what environment foreman is actually sending the
node.

Ā·Ā·Ā· On Thu, Jan 29, 2015 at 10:04 AM, Sigurdur Bjarnason < sigurdurfbjarnason@gmail.com> wrote:

Hi all!,

I just updated to Foreman 1.7.2 and since then my puppet agents are
picking up ā€œwrongā€ environments :confused:

running on the client I get

root@unstable:~# puppet agent --configprint environment
production

however the client is set to ā€œdevelopmentā€ in Foremanā€¦

Any clue?

Best Regards
Siggi

ā€“
You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.