ERF51-1518: Unable to find a proxy with BMC feature

How do I define a proxy with BMC feature enabled?
I could not find it in the documentation.
I have installed foreman-fog thinking it might be part of it, I also
re-enabled provisioning, and now I can define it, but I'm getting the error
in $SUBJECT.

TIA,
Y.

> How do I define a proxy with BMC feature enabled?
> I could not find it in the documentation.
> I have installed foreman-fog thinking it might be part of it, I also
> re-enabled provisioning, and now I can define it, but I'm getting the error
> in $SUBJECT.
>

on your proxy, check your config file… it should have the bmc section and
you could enable it there…

Ohad

··· On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul wrote:

TIA,
Y.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

Not there.
[root@foreman foreman-proxy]# pwd
/etc/foreman-proxy
[root@foreman foreman-proxy]# grep -v "#" settings.yml

··· ---

:ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem
:ssl_certificate: /var/lib/puppet/ssl/certs/foreman.xiolab.lab.emc.com.pem
:ssl_private_key:
/var/lib/puppet/ssl/private_keys/foreman.xiolab.lab.emc.com.pem

:daemon: true
:daemon_pid: /var/run/foreman-proxy/foreman-proxy.pid

:port: 8443

:tftp: false
:tftproot: /var/lib/tftpboot/
:tftp_servername: 10.76.221.92

:dns: false
:dns_key: /etc/rndc.key
:dns_server: 127.0.0.1

:dhcp: false
:dhcp_vendor: isc

:puppetca: true
:ssldir: /var/lib/puppet/ssl
:puppetdir: /etc/puppet

:puppet: true
:puppet_conf: /etc/puppet/puppet.conf

:log_file: /var/log/foreman-proxy/proxy.log

On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote:

On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul <myk...@gmail.com<javascript:> > > wrote:

How do I define a proxy with BMC feature enabled?
I could not find it in the documentation.
I have installed foreman-fog thinking it might be part of it, I also
re-enabled provisioning, and now I can define it, but I’m getting the error
in $SUBJECT.

on your proxy, check your config file… it should have the bmc section and
you could enable it there…

Ohad

TIA,
Y.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-user...@googlegroups.com <javascript:>.
To post to this group, send email to forema...@googlegroups.com<javascript:>
.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

> Not there.

right… you need to add it :wink: see [1] for example

Ohad

[1]

[root@foreman foreman-proxy]# pwd

··· On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul wrote: > /etc/foreman-proxy > [root@foreman foreman-proxy]# grep -v "\#" settings.yml > --- > > > :ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem > :ssl_certificate: /var/lib/puppet/ssl/certs/foreman.xiolab.lab.emc.com.pem > :ssl_private_key: > /var/lib/puppet/ssl/private_keys/foreman.xiolab.lab.emc.com.pem > > > :daemon: true > :daemon_pid: /var/run/foreman-proxy/foreman-proxy.pid > > :port: 8443 > > :tftp: false > :tftproot: /var/lib/tftpboot/ > :tftp_servername: 10.76.221.92 > > :dns: false > :dns_key: /etc/rndc.key > :dns_server: 127.0.0.1 > > :dhcp: false > :dhcp_vendor: isc > > :puppetca: true > :ssldir: /var/lib/puppet/ssl > :puppetdir: /etc/puppet > > :puppet: true > :puppet_conf: /etc/puppet/puppet.conf > > :log_file: /var/log/foreman-proxy/proxy.log > > > On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote: >> >> >> >> On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul wrote: >> >>> How do I define a proxy with BMC feature enabled? >>> I could not find it in the documentation. >>> I have installed foreman-fog thinking it might be part of it, I also >>> re-enabled provisioning, and now I can define it, but I'm getting the error >>> in $SUBJECT. >>> >> >> on your proxy, check your config file.. it should have the bmc section >> and you could enable it there.. >> >> Ohad >> >>> >>> TIA, >>> Y. >>> >>> -- >>> You received this message because you are subscribed to the Google >>> Groups "Foreman users" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to foreman-user...@**googlegroups.com. >>> To post to this group, send email to forema...@googlegroups.com**. >>> >>> Visit this group at http://groups.google.com/**group/foreman-users >>> . >>> For more options, visit https://groups.google.com/**groups/opt_out >>> . >>> >>> >>> >> >> -- > You received this message because you are subscribed to the Google Groups > "Foreman users" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to foreman-users+unsubscribe@googlegroups.com. > To post to this group, send email to foreman-users@googlegroups.com. > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/groups/opt_out. > > >

>
>
>
>> Not there.
>
>
> right… you need to add it :wink: see [1] for example
>
> Ohad
>
> [1]
> https://github.com/theforeman/smart-proxy/blob/develop/config/settings.yml.example#L77
>

Added, installed ipmitool RPM, installed the rubyipmi gem, restarted both
services (foreman and foreman-proxy), edited the proxy - now it found the
BMC.
Now it seems to work.
If I only had access to your redmine I might have filed both issues (lack
of default and lack of documentation).

Partially related - I don't have any logging into
/var/log/foreman-proxy/proxy.log. The file is 0 bytes long. I don't have
anything specific in the settings file for logging, but I do expect some
logging there.

··· On Monday, July 29, 2013 9:56:36 AM UTC+3, ohad wrote: > On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul <myk...@gmail.com > > wrote:

[root@foreman foreman-proxy]# pwd

/etc/foreman-proxy
[root@foreman foreman-proxy]# grep -v “#” settings.yml

:ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem
:ssl_certificate: /var/lib/puppet/ssl/certs/foreman.xiolab.lab.emc.com.pem
:ssl_private_key:
/var/lib/puppet/ssl/private_keys/foreman.xiolab.lab.emc.com.pem

:daemon: true
:daemon_pid: /var/run/foreman-proxy/foreman-proxy.pid

:port: 8443

:tftp: false
:tftproot: /var/lib/tftpboot/
:tftp_servername: 10.76.221.92

:dns: false
:dns_key: /etc/rndc.key
:dns_server: 127.0.0.1

:dhcp: false
:dhcp_vendor: isc

:puppetca: true
:ssldir: /var/lib/puppet/ssl
:puppetdir: /etc/puppet

:puppet: true
:puppet_conf: /etc/puppet/puppet.conf

:log_file: /var/log/foreman-proxy/proxy.log

On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote:

On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul myk...@gmail.com wrote:

How do I define a proxy with BMC feature enabled?
I could not find it in the documentation.
I have installed foreman-fog thinking it might be part of it, I also
re-enabled provisioning, and now I can define it, but I’m getting the error
in $SUBJECT.

on your proxy, check your config file… it should have the bmc section
and you could enable it there…

Ohad

TIA,
Y.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.

Visit this group at http://groups.google.com/**group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-user...@googlegroups.com <javascript:>.
To post to this group, send email to forema...@googlegroups.com<javascript:>
.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

also… when you get to the next level, you might need this

http://wiki.theforeman.org/projects/smart-proxy/wiki/BMC

Ohad

··· On Mon, Jul 29, 2013 at 9:56 AM, Ohad Levy wrote:

On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul mykaul@gmail.com wrote:

Not there.

right… you need to add it :wink: see [1] for example

Ohad

[1]
https://github.com/theforeman/smart-proxy/blob/develop/config/settings.yml.example#L77

[root@foreman foreman-proxy]# pwd

/etc/foreman-proxy
[root@foreman foreman-proxy]# grep -v “#” settings.yml

:ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem
:ssl_certificate: /var/lib/puppet/ssl/certs/foreman.xiolab.lab.emc.com.pem
:ssl_private_key:
/var/lib/puppet/ssl/private_keys/foreman.xiolab.lab.emc.com.pem

:daemon: true
:daemon_pid: /var/run/foreman-proxy/foreman-proxy.pid

:port: 8443

:tftp: false
:tftproot: /var/lib/tftpboot/
:tftp_servername: 10.76.221.92

:dns: false
:dns_key: /etc/rndc.key
:dns_server: 127.0.0.1

:dhcp: false
:dhcp_vendor: isc

:puppetca: true
:ssldir: /var/lib/puppet/ssl
:puppetdir: /etc/puppet

:puppet: true
:puppet_conf: /etc/puppet/puppet.conf

:log_file: /var/log/foreman-proxy/proxy.log

On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote:

On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul myk...@gmail.com wrote:

How do I define a proxy with BMC feature enabled?
I could not find it in the documentation.
I have installed foreman-fog thinking it might be part of it, I also
re-enabled provisioning, and now I can define it, but I’m getting the error
in $SUBJECT.

on your proxy, check your config file… it should have the bmc section
and you could enable it there…

Ohad

TIA,
Y.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.

Visit this group at http://groups.google.com/**group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

>
>
>>
>>
>>> Not there.
>>
>>
>> right… you need to add it :wink: see [1] for example
>>
>> Ohad
>>
>> [1] https://github.com/theforeman/smart-proxy/blob/
>> develop/config/settings.yml.**example#L77<https://github.com/theforeman/smart-proxy/blob/develop/config/settings.yml.example#L77>
>>
>
> Added, installed ipmitool RPM, installed the rubyipmi gem, restarted both
> services (foreman and foreman-proxy), edited the proxy - now it found the
> BMC.
> Now it seems to work.
>

> If I only had access to your redmine I might have filed both issues (lack
> of default and lack of documentation).
>
Why don't you have access to redmine?! (we are upgrading it today but didnt
start yet… )

>
> Partially related - I don't have any logging into
> /var/log/foreman-proxy/proxy.log. The file is 0 bytes long. I don't have
> anything specific in the settings file for logging, but I do expect some
> logging there.
>

you can turn on debug loggin on the proxy, we are aware that we need to
improve the proxy logging as a whole…

··· On Mon, Jul 29, 2013 at 10:22 AM, Yaniv Kaul wrote: > On Monday, July 29, 2013 9:56:36 AM UTC+3, ohad wrote: >> On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul wrote:

[root@foreman foreman-proxy]# pwd

/etc/foreman-proxy
[root@foreman foreman-proxy]# grep -v “#” settings.yml

:ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem
:ssl_certificate: /var/lib/puppet/ssl/certs/

foreman.xiolab.lab.emc.com.pem
:ssl_private_key: /var/lib/puppet/ssl/private_**
keys/foreman.xiolab.lab.emc.**com.pem

:daemon: true
:daemon_pid: /var/run/foreman-proxy/**foreman-proxy.pid

:port: 8443

:tftp: false
:tftproot: /var/lib/tftpboot/
:tftp_servername: 10.76.221.92

:dns: false
:dns_key: /etc/rndc.key
:dns_server: 127.0.0.1

:dhcp: false
:dhcp_vendor: isc

:puppetca: true
:ssldir: /var/lib/puppet/ssl
:puppetdir: /etc/puppet

:puppet: true
:puppet_conf: /etc/puppet/puppet.conf

:log_file: /var/log/foreman-proxy/proxy.**log

On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote:

On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul myk...@gmail.com wrote:

How do I define a proxy with BMC feature enabled?
I could not find it in the documentation.
I have installed foreman-fog thinking it might be part of it, I also
re-enabled provisioning, and now I can define it, but I’m getting the error
in $SUBJECT.

on your proxy, check your config file… it should have the bmc section
and you could enable it there…

Ohad

TIA,
Y.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@**googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.

Visit this group at http://groups.google.com/group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.
Visit this group at http://groups.google.com/**group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

>
>
>
>>
>>
>>>
>>>
>>>> Not there.
>>>
>>>
>>> right… you need to add it :wink: see [1] for example
>>>
>>> Ohad
>>>
>>> [1] https://github.com/theforeman/smart-proxy/blob/
>>> develop/config/settings.yml.**example#L77<https://github.com/theforeman/smart-proxy/blob/develop/config/settings.yml.example#L77>
>>>
>>
>> Added, installed ipmitool RPM, installed the rubyipmi gem, restarted both
>> services (foreman and foreman-proxy), edited the proxy - now it found the
>> BMC.
>> Now it seems to work.
>>
>
>
>> If I only had access to your redmine I might have filed both issues (lack
>> of default and lack of documentation).
>>
> Why don't you have access to redmine?! (we are upgrading it today but
> didnt start yet… )
>

I don't remember my password, and the reminder email never gets through.
I'm pretty sure I've complained about this before.

>
>> Partially related - I don't have any logging into
>> /var/log/foreman-proxy/proxy.log. The file is 0 bytes long. I don't have
>> anything specific in the settings file for logging, but I do expect some
>> logging there.
>>
>
> you can turn on debug loggin on the proxy, we are aware that we need to
> improve the proxy logging as a whole…
>

There is no logging whatsoever. Default logging == no logging?

Y.

··· On Monday, July 29, 2013 10:30:22 AM UTC+3, ohad wrote: > On Mon, Jul 29, 2013 at 10:22 AM, Yaniv Kaul <myk...@gmail.com > > wrote: >> On Monday, July 29, 2013 9:56:36 AM UTC+3, ohad wrote: >>> On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul wrote:

[root@foreman foreman-proxy]# pwd

/etc/foreman-proxy
[root@foreman foreman-proxy]# grep -v “#” settings.yml

:ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem
:ssl_certificate: /var/lib/puppet/ssl/certs/

foreman.xiolab.lab.emc.com.pem
:ssl_private_key: /var/lib/puppet/ssl/private_**
keys/foreman.xiolab.lab.emc.**com.pem

:daemon: true
:daemon_pid: /var/run/foreman-proxy/**foreman-proxy.pid

:port: 8443

:tftp: false
:tftproot: /var/lib/tftpboot/
:tftp_servername: 10.76.221.92

:dns: false
:dns_key: /etc/rndc.key
:dns_server: 127.0.0.1

:dhcp: false
:dhcp_vendor: isc

:puppetca: true
:ssldir: /var/lib/puppet/ssl
:puppetdir: /etc/puppet

:puppet: true
:puppet_conf: /etc/puppet/puppet.conf

:log_file: /var/log/foreman-proxy/proxy.**log

On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote:

On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul myk...@gmail.com wrote:

How do I define a proxy with BMC feature enabled?
I could not find it in the documentation.
I have installed foreman-fog thinking it might be part of it, I also
re-enabled provisioning, and now I can define it, but I’m getting the error
in $SUBJECT.

on your proxy, check your config file… it should have the bmc section
and you could enable it there…

Ohad

TIA,
Y.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to foreman-user…@**googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.

Visit this group at http://groups.google.com/group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.
Visit this group at http://groups.google.com/**group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-user...@googlegroups.com <javascript:>.
To post to this group, send email to forema...@googlegroups.com<javascript:>
.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

>
>
>
>
>
>
>
>
> Not there.
>
>
> right… you need to add it :wink: see [1] for example
>
> Ohad
>
> [1]
> https://github.com/__theforeman/smart-proxy/blob/__develop/config/settings.yml.__example#L77
> <https://github.com/theforeman/smart-proxy/blob/develop/config/settings.yml.example#L77>
>
>
> Added, installed ipmitool RPM, installed the rubyipmi gem,
> restarted both services (foreman and foreman-proxy), edited the
> proxy - now it found the BMC.
> Now it seems to work.
>
>
>
> If I only had access to your redmine I might have filed both
> issues (lack of default and lack of documentation).
>
> Why don't you have access to redmine?! (we are upgrading it today
> but didnt start yet… )
>
>
> I don't remember my password, and the reminder email never gets through.
> I'm pretty sure I've complained about this before.

I just activated your account, you should be able to log in.

> Partially related - I don't have any logging into
> /var/log/foreman-proxy/proxy.log. The file is 0 bytes long. I
> don't have anything specific in the settings file for logging,
> but I do expect some logging there.
>
>
> you can turn on debug loggin on the proxy, we are aware that we need
> to improve the proxy logging as a whole…
>
>
> There is no logging whatsoever. Default logging == no logging?

No, try restarting the proxy. Perhaps there's an issue with the
logrotation setup. Can you try adding "copytruncate" to the logrotate
config and see if it recurs tomorrow?

··· On 29/07/13 08:38, Yaniv Kaul wrote: > On Monday, July 29, 2013 10:30:22 AM UTC+3, ohad wrote: > On Mon, Jul 29, 2013 at 10:22 AM, Yaniv Kaul > wrote: > On Monday, July 29, 2013 9:56:36 AM UTC+3, ohad wrote: > On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul > wrote:


Dominic Cleal
Red Hat Engineering

>
>
>>
>>
>>>
>>>
>>>>
>>>>
>>>>> Not there.
>>>>
>>>>
>>>> right… you need to add it :wink: see [1] for example
>>>>
>>>> Ohad
>>>>
>>>> [1] https://github.com/theforeman/smart-proxy/blob/develop/
>>>> config/settings.yml.**example#**L77<https://github.com/theforeman/smart-proxy/blob/develop/config/settings.yml.example#L77>
>>>>
>>>
>>> Added, installed ipmitool RPM, installed the rubyipmi gem, restarted
>>> both services (foreman and foreman-proxy), edited the proxy - now it found
>>> the BMC.
>>> Now it seems to work.
>>>
>>
>>
>>> If I only had access to your redmine I might have filed both issues
>>> (lack of default and lack of documentation).
>>>
>> Why don't you have access to redmine?! (we are upgrading it today but
>> didnt start yet… )
>>
>
> I don't remember my password, and the reminder email never gets through.
> I'm pretty sure I've complained about this before
>
OK… double check your spam… alternatively i can reactive your account…
feel free to forward the details on a private email or on irc.

> .
>
>
>>
>>> Partially related - I don't have any logging into
>>> /var/log/foreman-proxy/proxy.**log. The file is 0 bytes long. I don't
>>> have anything specific in the settings file for logging, but I do expect
>>> some logging there.
>>>
>>
>> you can turn on debug loggin on the proxy, we are aware that we need to
>> improve the proxy logging as a whole…
>>
>
> There is no logging whatsoever. Default logging == no logging?
>
> AFAIR only when the proxy perform an operation… feel free to open a bug
on it.

··· On Mon, Jul 29, 2013 at 10:38 AM, Yaniv Kaul wrote: > On Monday, July 29, 2013 10:30:22 AM UTC+3, ohad wrote: >> On Mon, Jul 29, 2013 at 10:22 AM, Yaniv Kaul wrote: >>> On Monday, July 29, 2013 9:56:36 AM UTC+3, ohad wrote: >>>> On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul wrote:

Y.

[root@foreman foreman-proxy]# pwd

/etc/foreman-proxy
[root@foreman foreman-proxy]# grep -v “#” settings.yml

:ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem
:ssl_certificate: /var/lib/puppet/ssl/certs/fore
man.xiolab.lab.emc.com.pem
:ssl_private_key: /var/lib/puppet/ssl/private_ke
ys/foreman.xiolab.lab.emc.**com.**pem

:daemon: true
:daemon_pid: /var/run/foreman-proxy/foreman-proxy.pid

:port: 8443

:tftp: false
:tftproot: /var/lib/tftpboot/
:tftp_servername: 10.76.221.92

:dns: false
:dns_key: /etc/rndc.key
:dns_server: 127.0.0.1

:dhcp: false
:dhcp_vendor: isc

:puppetca: true
:ssldir: /var/lib/puppet/ssl
:puppetdir: /etc/puppet

:puppet: true
:puppet_conf: /etc/puppet/puppet.conf

:log_file: /var/log/foreman-proxy/proxy.log

On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote:

On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul myk...@gmail.com wrote:

How do I define a proxy with BMC feature enabled?
I could not find it in the documentation.
I have installed foreman-fog thinking it might be part of it, I also
re-enabled provisioning, and now I can define it, but I’m getting the error
in $SUBJECT.

on your proxy, check your config file… it should have the bmc
section and you could enable it there…

Ohad

TIA,
Y.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.

Visit this group at http://groups.google.com/group**
/foreman-users http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/grou**
ps/opt_out https://groups.google.com/groups/opt_out.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@**googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.
Visit this group at http://groups.google.com/group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.
Visit this group at http://groups.google.com/**group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

Hello,

Juste as a follow-up of this discussion, I wrote an english blog post about
BMC installation and configuration :
http://www.fitzdsl.net/en/2013/07/controlez-lalimentation-de-vos-serveurs-avec-foreman/

Regards,

··· 2013/7/29 Ohad Levy

On Mon, Jul 29, 2013 at 10:38 AM, Yaniv Kaul mykaul@gmail.com wrote:

On Monday, July 29, 2013 10:30:22 AM UTC+3, ohad wrote:

On Mon, Jul 29, 2013 at 10:22 AM, Yaniv Kaul myk...@gmail.com wrote:

On Monday, July 29, 2013 9:56:36 AM UTC+3, ohad wrote:

On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul myk...@gmail.com wrote:

Not there.

right… you need to add it :wink: see [1] for example

Ohad

[1] https://github.com/theforeman/smart-proxy/blob/develop/
config/settings.yml.**example#**L77https://github.com/theforeman/smart-proxy/blob/develop/config/settings.yml.example#L77

Added, installed ipmitool RPM, installed the rubyipmi gem, restarted
both services (foreman and foreman-proxy), edited the proxy - now it found
the BMC.
Now it seems to work.

If I only had access to your redmine I might have filed both issues
(lack of default and lack of documentation).

Why don’t you have access to redmine?! (we are upgrading it today but
didnt start yet… )

I don’t remember my password, and the reminder email never gets through.
I’m pretty sure I’ve complained about this before

OK… double check your spam… alternatively i can reactive your account…
feel free to forward the details on a private email or on irc.

.

Partially related - I don’t have any logging into
/var/log/foreman-proxy/proxy.**log. The file is 0 bytes long. I don’t
have anything specific in the settings file for logging, but I do expect
some logging there.

you can turn on debug loggin on the proxy, we are aware that we need to
improve the proxy logging as a whole…

There is no logging whatsoever. Default logging == no logging?

AFAIR only when the proxy perform an operation… feel free to open a bug
on it.

Y.

[root@foreman foreman-proxy]# pwd

/etc/foreman-proxy
[root@foreman foreman-proxy]# grep -v “#” settings.yml

:ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem
:ssl_certificate: /var/lib/puppet/ssl/certs/fore
man.xiolab.lab.emc.com.pem
:ssl_private_key: /var/lib/puppet/ssl/private_ke
ys/foreman.xiolab.lab.emc.**com.**pem

:daemon: true
:daemon_pid: /var/run/foreman-proxy/foreman-proxy.pid

:port: 8443

:tftp: false
:tftproot: /var/lib/tftpboot/
:tftp_servername: 10.76.221.92

:dns: false
:dns_key: /etc/rndc.key
:dns_server: 127.0.0.1

:dhcp: false
:dhcp_vendor: isc

:puppetca: true
:ssldir: /var/lib/puppet/ssl
:puppetdir: /etc/puppet

:puppet: true
:puppet_conf: /etc/puppet/puppet.conf

:log_file: /var/log/foreman-proxy/proxy.log

On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote:

On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul myk...@gmail.comwrote:

How do I define a proxy with BMC feature enabled?
I could not find it in the documentation.
I have installed foreman-fog thinking it might be part of it, I
also re-enabled provisioning, and now I can define it, but I’m getting the
error in $SUBJECT.

on your proxy, check your config file… it should have the bmc
section and you could enable it there…

Ohad

TIA,
Y.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.

Visit this group at http://groups.google.com/group**
/foreman-users http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/grou**
ps/opt_out https://groups.google.com/groups/opt_out.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it,
send an email to foreman-user…@**googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.
Visit this group at http://groups.google.com/group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google
Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send
an email to foreman-user…@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com
.
Visit this group at http://groups.google.com/**group/foreman-usershttp://groups.google.com/group/foreman-users
.
For more options, visit https://groups.google.com/**groups/opt_outhttps://groups.google.com/groups/opt_out
.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.


You received this message because you are subscribed to the Google Groups
"Foreman users" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

Thanks Romain for this tutorial.

I followed the instructions in this thread and in Romain's tutorial but I
still had problems. I also had to make two additional changes: Poke the
Smart Proxy so that it realizes that it should also be a BMC Smart Proxy,
and restart the Smart Proxy process.

  1. Sanity check:

[root@foreman ~]# grep bmc /etc/foreman-proxy/settings.yml
:bmc: true
:bmc_default_provider: ipmitool
[root@foreman ~]# service foreman-proxy restart
Stopping foreman-proxy: [ OK ]
Starting foreman-proxy: [ OK ]
[root@foreman ~]#

  1. Then I visited https://foreman.example.org/smart_proxies and I noticed
    that BMC was not listed as a Smart Proxy. It said:

Name URL Features
foreman.example.org https://foreman.example.org:8443 DHCP, DNS,
Puppet, Puppet CA, and TFTP

  1. I clicked on the hostname of the proxy to enter the 'Edit' screen, made
    no changes and then hit 'Submit'. Now
    https://foreman.example.org/smart_proxies says:

Name URL Features
foreman.example.org https://foreman.example.org:8443 BMC, DHCP, DNS,
Puppet, Puppet CA, and TFTP

  1. But I am still getting the error "ERF51-1518: Unable to find a proxy
    with BMC feature". So I restarted the smart-proxy once again, and NOW I see
    information under the BMC tab.

-= Stefan

··· On Monday, July 29, 2013 12:46:26 AM UTC-7, Romain Vrignaud wrote: > > Hello, > > Juste as a follow-up of this discussion, I wrote an english blog post > about BMC installation and configuration : > > http://www.fitzdsl.net/en/2013/07/controlez-lalimentation-de-vos-serveurs-avec-foreman/ > > Regards, > > > 2013/7/29 Ohad Levy <ohad...@gmail.com > > >> >> >> On Mon, Jul 29, 2013 at 10:38 AM, Yaniv Kaul <myk...@gmail.com >> > wrote: >> >>> On Monday, July 29, 2013 10:30:22 AM UTC+3, ohad wrote: >>> >>> >>>> >>>> On Mon, Jul 29, 2013 at 10:22 AM, Yaniv Kaul wrote: >>>> >>>>> On Monday, July 29, 2013 9:56:36 AM UTC+3, ohad wrote: >>>>> >>>>> >>>>>> >>>>>> On Mon, Jul 29, 2013 at 9:35 AM, Yaniv Kaul wrote: >>>>>> >>>>>>> Not there. >>>>>> >>>>>> >>>>>> right.. you need to add it ;) see [1] for example >>>>>> >>>>>> Ohad >>>>>> >>>>>> [1] https://github.com/theforeman/smart-proxy/blob/develop/ >>>>>> config/settings.yml.example#L77 >>>>>> >>>>> >>>>> Added, installed ipmitool RPM, installed the rubyipmi gem, restarted >>>>> both services (foreman and foreman-proxy), edited the proxy - now it found >>>>> the BMC. >>>>> Now it seems to work. >>>>> >>>> >>>> >>>>> If I only had access to your redmine I might have filed both issues >>>>> (lack of default and lack of documentation). >>>>> >>>> Why don't you have access to redmine?! (we are upgrading it today but >>>> didnt start yet.. ) >>>> >>> >>> I don't remember my password, and the reminder email never gets through. >>> I'm pretty sure I've complained about this before >>> >> OK.. double check your spam.. alternatively i can reactive your >> account... feel free to forward the details on a private email or on irc. >> >>> . >>> >>> >>>> >>>>> Partially related - I don't have any logging into >>>>> /var/log/foreman-proxy/proxy.log. The file is 0 bytes long. I don't >>>>> have anything specific in the settings file for logging, but I do expect >>>>> some logging there. >>>>> >>>> >>>> you can turn on debug loggin on the proxy, we are aware that we need to >>>> improve the proxy logging as a whole.. >>>> >>> >>> There is no logging whatsoever. Default logging == no logging? >>> >>> AFAIR only when the proxy perform an operation... feel free to open a >> bug on it. >> >>> Y. >>> >>> >>>> >>>> >>>> >>>>> >>>>> >>>>>> >>>>>> [root@foreman foreman-proxy]# pwd >>>>>>> /etc/foreman-proxy >>>>>>> [root@foreman foreman-proxy]# grep -v "\#" settings.yml >>>>>>> --- >>>>>>> >>>>>>> >>>>>>> :ssl_ca_file: /var/lib/puppet/ssl/certs/ca.pem >>>>>>> :ssl_certificate: /var/lib/puppet/ssl/certs/fore >>>>>>> man.xiolab.lab.emc.com.pem >>>>>>> :ssl_private_key: /var/lib/puppet/ssl/private_ke >>>>>>> ys/foreman.xiolab.lab.emc.com.pem >>>>>>> >>>>>>> >>>>>>> :daemon: true >>>>>>> :daemon_pid: /var/run/foreman-proxy/foreman-proxy.pid >>>>>>> >>>>>>> :port: 8443 >>>>>>> >>>>>>> :tftp: false >>>>>>> :tftproot: /var/lib/tftpboot/ >>>>>>> :tftp_servername: 10.76.221.92 >>>>>>> >>>>>>> :dns: false >>>>>>> :dns_key: /etc/rndc.key >>>>>>> :dns_server: 127.0.0.1 >>>>>>> >>>>>>> :dhcp: false >>>>>>> :dhcp_vendor: isc >>>>>>> >>>>>>> :puppetca: true >>>>>>> :ssldir: /var/lib/puppet/ssl >>>>>>> :puppetdir: /etc/puppet >>>>>>> >>>>>>> :puppet: true >>>>>>> :puppet_conf: /etc/puppet/puppet.conf >>>>>>> >>>>>>> :log_file: /var/log/foreman-proxy/proxy.log >>>>>>> >>>>>>> >>>>>>> On Sunday, July 28, 2013 4:52:50 PM UTC+3, ohad wrote: >>>>>>>> >>>>>>>> >>>>>>>> >>>>>>>> On Sun, Jul 28, 2013 at 3:09 PM, Yaniv Kaul wrote: >>>>>>>> >>>>>>>>> How do I define a proxy with BMC feature enabled? >>>>>>>>> I could not find it in the documentation. >>>>>>>>> I have installed foreman-fog thinking it might be part of it, I >>>>>>>>> also re-enabled provisioning, and now I can define it, but I'm getting the >>>>>>>>> error in $SUBJECT. >>>>>>>>> >>>>>>>> >>>>>>>> on your proxy, check your config file.. it should have the bmc >>>>>>>> section and you could enable it there.. >>>>>>>> >>>>>>>> Ohad >>>>>>>> >>>>>>>>> >>>>>>>>> TIA, >>>>>>>>> Y. >>>>>>>>> >>>>>>>>> -- >>>>>>>>> You received this message because you are subscribed to the Google >>>>>>>>> Groups "Foreman users" group. >>>>>>>>> To unsubscribe from this group and stop receiving emails from it, >>>>>>>>> send an email to foreman-user...@googlegroups.com. >>>>>>>>> To post to this group, send email to forema...@googlegroups.com. >>>>>>>>> >>>>>>>>> Visit this group at http://groups.google.com/group/foreman-users. >>>>>>>>> For more options, visit https://groups.google.com/groups/opt_out. >>>>>>>>> >>>>>>>>> >>>>>>>>> >>>>>>>> >>>>>>>> -- >>>>>>> You received this message because you are subscribed to the Google >>>>>>> Groups "Foreman users" group. >>>>>>> To unsubscribe from this group and stop receiving emails from it, >>>>>>> send an email to foreman-user...@googlegroups.com. >>>>>>> To post to this group, send email to forema...@googlegroups.com. >>>>>>> Visit this group at http://groups.google.com/group/foreman-users. >>>>>>> For more options, visit https://groups.google.com/groups/opt_out. >>>>>>> >>>>>>> >>>>>>> >>>>>> >>>>>> -- >>>>> You received this message because you are subscribed to the Google >>>>> Groups "Foreman users" group. >>>>> To unsubscribe from this group and stop receiving emails from it, send >>>>> an email to foreman-user...@googlegroups.com. >>>>> To post to this group, send email to forema...@googlegroups.com. >>>>> Visit this group at http://groups.google.com/group/foreman-users. >>>>> For more options, visit https://groups.google.com/groups/opt_out. >>>>> >>>>> >>>>> >>>> >>>> -- >>> You received this message because you are subscribed to the Google >>> Groups "Foreman users" group. >>> To unsubscribe from this group and stop receiving emails from it, send >>> an email to foreman-user...@googlegroups.com . >>> To post to this group, send email to forema...@googlegroups.com >>> . >>> Visit this group at http://groups.google.com/group/foreman-users. >>> For more options, visit https://groups.google.com/groups/opt_out. >>> >>> >>> >> >> -- >> You received this message because you are subscribed to the Google Groups >> "Foreman users" group. >> To unsubscribe from this group and stop receiving emails from it, send an >> email to foreman-user...@googlegroups.com . >> To post to this group, send email to forema...@googlegroups.com >> . >> Visit this group at http://groups.google.com/group/foreman-users. >> For more options, visit https://groups.google.com/groups/opt_out. >> >> >> > >