Error when running rake db:seed command

I get this error when running rake:db seed as a foreman user. I thought it was an issue with the ‘apipie-rails’ gem but when I included it in the gemfile and the file that seems to be producing the error, I still get the same result.

Is this a source or packaged install? which distro are you on?

Or actually, why are you running it with sudo? try bundle exec rake db:seed if this is a source install or foreman-rake db:seed if it’s from packages

It’s a source install. I tried running bundle exec rake db:seed and the error is no longer showing up but I’m still getting some errors regarding gems. I’ll try to fix them and provide you with an update.

Update: I got the bundle exec rake db:seed command to work, but I can’t get my IPAM feature (In the smart proxy plugin that I’m working on) to show up in the foreman interface. I created a seed file for it and it shows up in the logs when I run the command but not on the interface.

Never mind, I got the feature to work.

1 Like