Error while run foreman-installer

hi all,

when I run

foreman-installer --noop

I get :

2021-09-08 07:12:57 [ERROR ] [configure] /Stage[main]/Foreman::Database::Postgresql/Postgresql::Server::Db[foreman]/Postgresql::Server::Role[foreman]/Postgresql_psql[CREATE ROLE foreman ENCRYPTED PASSWORD ****]: Could not evaluate: Error evaluating ‘unless’ clause, returned pid 6214 exit 1: 'Error: Could not execute posix command: Invalid group: postgres

Do I have to create this group: postgres ?

On Test Machine I have those two groups for postgres:

but when I try to install that on Production machine I get above error, and the groups are not available in /etc/groups

Thanks in advance

More informations:
Foreman Version 3.0: Foreman :: Quickstart
foreman-installer 3.0.0~rc2-1 Automated puppet-based installer for The Foreman

The announcment is new :smiley:

Not yet released

This quickstart guide is for Foreman 3.0, but 2.5 is the current stable version.

When is the release date for 3.0 ?

The 3.0.0 is released as I can see here:

but not in the Foreman repo, does anyone have more informations about it ?

Foreman 3.0 isn’t released yet. It is coming in the next while.

There are some docs available on our site because we ask the community to help us by testing our release candidates. For example: Foreman 3.0.0 RC2 is available for testing - the second release candidate is available at the moment and the more people who use it and tell us about their experience, the more stable the forthcoming release will be.

We will announce the release as soon as it is ready here, update our site, and on social media/demo etc. You can find all the latest release information and prep in our release announcement section: Release Announcements - TheForeman

You can keep track of the Foreman 3.0 release process here: Foreman 3.0.0(GA) release process

1 Like

thnaks for your answer @mcorr , do you have any idea about my Error how can I solve it ?
I install now the 3.0.0~rc2-1

Hey @Neeloj - off hand I don’t know.

Are you installing onto a server that is used or configured for other things too?
What operating system are you using?

I install foreman-installer 3.0 on my test machine, it works.

So now I want to install that on my production machine but I get above error.

Both are Ubuntu 18.03

by the way:

From your link , it doesnt mean that stable but its not released yet ? The Jenikins Test is okay and green :slight_smile:

Is there any material difference between your test and production environments?
What have you been using the production environment for up until now?

Definitely not released yet, but everyone is working hard.

1 Like

no both are ubuntu 18.04

  1. sudo apt-get -y install foreman-installer
  2. foreman-installer -noop
    and while configuration I get above error

Thank you all :slight_smile:

What I am trying to say is the OS is less important than what might have happened already on that server before you started to install Foreman.

Foreman server must be installed on a freshly provisioned system that serves no other function except to run Foreman server. The freshly provisioned system must not have the following users provided by external identity providers to avoid conflicts with the local users that Foreman server creates:






Can you take a look at this list ^

very good questions @mcorr :-).

we have already puppetserver/puppet-agent on my prod server, so the puppet user is already created because I use puppetserver.

1 Like

I had a feeling it was going to be related to something like this.

Install Foreman on a fresh server used for nothing else and then use these docs

But I dont use Hammer!
I run below two commands:

  • sudo apt-get -y install foreman-installer
  • foreman-installer -noop

I think the --noop make the problem! Because this is the only different thing which I add it in compare to my test machine :smiley:

Yeah, pretty sure --noop on the first run won’t work. --noop means “don’t actually do any changes to the system”, but the installer relies on the system being actually a working Foreman for that, and on the first run, it is not yet the case.

@ekohl might want to weight in, but I don’t think this is something we’d aim to support.


You are so RIGHT!!! its first run!!

because of that I didnot get that error on my Test machine!!! Because I run it without --noop

@evgeni do you know when the 3.0 stable will be released ?

I would expect 3.0 to be released this week. (No guarantees, etc, but we’re pretty far in the process already).

1 Like

Beacause I dont want have RC on my prod machine! Ill wait until you release it :slight_smile:

thank you so much and Ill mark it as solution :slight_smile: