Errors during installation of Foreman 1.19 on Centos 7

Problem: Hello Everyone, I hope you can help me with this problem. I’m getting error messages when trying to install Foreman 1.19 on Centos 7. Installation log is attached to this post. After the installation I can log in to admin panel but it’s not showing Puppet server components. The OS is fully updated and is:

vSphere 6.5 VM
CPU: 4 cores
Memory: 8 GB
Disk: 40 GB

I’ve checked DNS resolution, removed “localhost” entries from /etc/hosts, checked reverse-DNS. “facter fqdn” and “hostname -f” display the same fqdn of my server.

I’ve tried installation 3 times but with no luck. However, it worked perfectly fine on Ubuntu 18.04. Every time, I followed quick installation guide.

Installation log (uploaded to Onedrive):!AjneyQBgwSP2g5pXuff-gRmlYuH01Q

Thank you for your help,

Could you please better describe what you expect to see and what’s not there? I’m not sure what is missing there. Thanks.

Thanks for reply. I would like to start using Foreman by integrating it with Puppet. I am going to use Puppet master installed by default with Foreman. When I installed it on Ubuntu 18.04, I could see Puppet master just after logging in to Foreman panel: the host was available, there was an option to import classes etc. With Centos 7 deployment, I can see only an empty admin panel. All default options are available but the host is not appearing, so it looks like integration between Foreman and Puppet is broken (?).

I assume that these error messages from the log are the problem. I’m new to Foreman and obviously I tried to google for the solution and checked documentation but I couldn’t find anything that match my scenario.

So, I managed to solve this issue. I had a custom proxy configuration redirecting connections made to Foreman… I added local proxy exceptions and a whole installation went correctly. Really stupid mistake…