Facing 2 problems after upgrading from 2.4.0 to 2.5.0

Hi, i’m facing 2 problems after upgrading to 2.5, everything is now in version 2.5, foreman servers and proxies.

  1. After upgrade, foreman was not receiving puppet reports anymore, facts were ok but not reports.
    In the log i had the following error :
    No smart proxy server found on [“my_puppet_proxy_fqdn”] and is not in trusted_hosts
    I’ve solved this issue by adding puppet proxy fqdn in the trusted_hosts parameter, but it should work without this.

  2. After upgrade i wanted to rebuild a host, and it failed with a TFTP timeout error. Looking at file /var/lib/dhcpd/dhcpd.leases, the rebuild action now set a value of false on the line supersede server.next-server instead of the ip address in hexa format.
    Forcing :tftp_servername: my_tftp_proxy_fqdn does not resolve the issue.
    The only way for rebuild to work is editing the dhcpd.leases file and replacing “false” by the hexa ip address.

Any help would be appreciated.


1 Like

This suggests the Puppet feature is not detected on the Smart Proxy.

1 Like

In Foreman interface, Infrastructure->Smart Proxies, the proxy has green status with Logs,Puppet,Puppet CA, and Registration features.

Then it should actually find a smart proxy for that. That’s odd. Is there perhaps a mismatch on the certificate name and the URl it’s registered as?

No there is no mismatch, everything was working as expected in 2.4.0, this behaviour only changed after upgrading to 2.5.0, did not change any config param nor certificate anywhere.

Ad 1) that’s really weird. AFAIK the code that authenticates facts and reports is the same. Did you install the puppet plugin by any chance? It should not affect this part but stil…

Ad 2) the feels like an issue in the installer or perhaps when you ran the installer during the upgrade, it applied the old value that you may have changed manually since the last upgrade. Can you check foreman-installer --help | grep servername? Is the default UNDEF? I think this option only accepts the IP address, not a hostname/fqdn.

I had a similar issue like item 1. I updated puppet from ver 5 to ver 6 and the reports where properly populating again. I am running it on Ubuntu 18.04.

I am seeing the same issue with the dhcpd.leases file.
This is what I am seeing:
supersede server.next-server = “false”;
The next-server value during install is UNDEF.
[root@ss-hn1 foreman-proxy]# foreman-installer --help | grep servername
–foreman-proxy-tftp-servername Defines the TFTP Servername to use, overrides the name in the subnet declaration (current: UNDEF)

This is what I am seeing in the proxy.log file:
2021-06-30T13:59:58 5356466a [I] Next-server option not IPv4, trying to resolve ‘false’
2021-06-30T13:59:58 5356466a [W] Unable to resolve PTR query for ‘false’, will use the hostname

Looks like a bug.