FDI image not available

We did some changes on our foreman installation this morning.
When running the foreman-installer we got this message:

2021-07-27 09:33:41 [ERROR ] [configure] /Stage[main]/Foreman_proxy::Plugin::Discovery/Foreman_proxy::Remote_file[/srv/tftp/boot/fdi-image-latest.tar]/File[/srv/tftp/boot/fdi-image-latest.tar]: Could not evaluate: Could not retrieve information from environment production source(s) http://downloads.theforeman.org/discovery/releases/latest/fdi-image-latest.tar

I tried to reach http://downloads.theforeman.org/discovery/releases/latest/fdi-image-latest.tar directly which is also not reachable.

Hi, looks like a dangling symlink somewhere on our servers. As far as I know, latest is 3.8.0, which you can grab from here[1] if that helps anything. Maybe if you place it correctly, puppet won’t try to download it?

[1] - https://downloads.theforeman.org/discovery/releases/3.8/fdi-image-latest.tar

Thank you @aruzicka. I tried that, the foreman-installer still shows the error.
We will wait until the missing symlink is fixed. Thanks for your fast response. :slight_smile:

I’ve fixed the symlink and purged the cache. This should work again. Thanks for reporting!


Looks much better now. Thank you @ekohl!