Foreman 2.1 Installation Runs into Response 502 Error on Centos7

running foreman-installer results in

/Stage[main]/Foreman_proxy::Register/Foreman_smartproxy[]: Could not evaluate: Proxy cannot be retrieved: unknown error (response 502)

hostname -f

::1 localhost localhost.localdomain localhost6 localhost6.localdomain6

Other relevant data:

I have tried disabling firewall, restarting of system. Would appreciate if anyone can provide troubleshooting advice.

Let me know if any further logs would be helpful.


Hi ,
I do have the same error and i can able to resolve dns .
Did you able to fix the same error ?
I am using Foreman 2.1.3 and katello 3.16

Hi, I wasn’t able to fix it. How did you manage to resolve it?

I have the same version of Foreman and katello as well

I couldn’t resolve too.
Still working on that.

Do update here if you have any progress. In the meantime can i check if you see any warning or error messages in your


Getting the following errors on proxy.log

[root@sat ~]# cat /var/log/foreman-proxy/proxy.log
2020-10-11T23:24:41 [E] Disabling all modules in the group [‘dhcp_isc’, ‘dhcp’] due to a failure in one of them: File at ‘/etc/dhcp/dhcpd.conf’ defined in ‘config’ parameter doesn’t exist or is unreadable


2020-10-12T08:50:02 [I] WEBrick::HTTPServer#start: pid=29788 port=9090
2020-10-12T08:50:02 [I] Smart proxy has launched on 1 socket(s), waiting for requests
2020-10-12T08:52:43 [W] Failed to initialize puppet class cache, deferring initialization. Is puppetserver running?
[root@sat ~]#

This is Bug #30962: dhcpd.conf file-ACLs are reset - Installer - Foreman which will be fixed in 2.1.4, as a workaround you need to ensure that the foreman-proxy user has read access to /etc/dhcp/ and /etc/dhcp/dhcpd.conf and restart the smart-proxy service.


Thanks a lot i can able to start foreman-proxy now.