Foreman-ansible integration fails with 'Proxy error: RuntimeError'

Hi all,

I'm trying to integrate Ansible with our existing Foreman infrastructure,
"think" I did all the steps correctly:

  • Enable Foreman-Ansible plugin at Foreman server in order to receive
    Ansible facts
  • Enable Foreman callback in Ansible to forward the facts to Foreman.
  • (Optional) Enable Dynamic inventory in Ansible with Foreman, it works!
  • Install foreman-ansible-proxy on Ansible server
  • Import Ansible roles from Ansible server to Foreman

Everything worked great until I tried to apply a Ansible role to a host, it
fails with:
Proxy error: RuntimeError - Ansible dir /etc/ansible does not exist

threw from dynflow, Please see the attached screenshot.

I'm using the latest Foreman version 1.15 on Foreman server (Debian Jessie)
same version of Foreman-proxy on Ansible server (Ubuntu Xenial).
Ansible itself is the latest 2.3.

The symptom almost suggests it's looking for /etc/ansible at local Foreman
server, but I'm sure it's not that simply.
I also debug foreman-proxy on remote Ansible machine but found no valuable

Could someone advice what might possible going wrong?
Thank you.