Foreman class importing always detects modified classes

I'm using TheForeman 1.6 with several environments and it's showing some
strange behaviour when I import classes using the web tool.

I have separate environments like production, development, qa, and a common
one with modules to be deployed in all environments servers, but this is
happening from before I set up the common env, so I thing it's not related
to this issue.

The problem lays within the change detection of identically named modules
spread across the enviroments. They share most of the code and module
names, but there are slight differences between them, mostly parameter
assignation, but TheForeman is always detecting changes in those modules
even when they haven't been modified for weeks. Every time I import
classes, there is a notification of modified modules that haven't actually
been modified.

I'm rewriting some of the modules using a case ::$environment switch to
assign different variables to the parameters, depending on the enviroment
each client is assigned to, but I would like to know if there is any
workaround to debug the modification detection. I've tried with foreman-rake
puppet:import:puppet_classes --trace but I get no additional information,
only Evaluating possible changes to your installation - No changes detected,
which is the expected but not the same result the web interface is giving


Any ideas? Thanks in advance!

PD: Sorry for my English, it's not my native language.