Foreman discovery VLAN pxe boot


I’m doing pxe boot with tagged vlan.

Discovery shows this error:

I see the host in discovery list only under admin user though and have to manually move it (primary interface doesn’t have ip address, vlan interface - does)

Without VLANs everything works just fine.

Discovery has an option for configuring the VLAN on the primary interface, maybe try adding this option to the kernel cmdline:


(where 10 of course is the VLAN)

Actually something interesting I found today.

Network owned by org - ORG2

I added custom zip archive and specified to force using foreman_ogganization = ORG1 instead.

See the same error.

Looks like it’s a bug which’s already reported:

I’ll do some workarounds with custom facts.

Yes, the options is in place in my setup.

Looks like discovery image is confused with vlan itself and cannot figure out which interface is primary. With vlan or without.

Sorry fo the confusion. I meant similar setup without trunking on access ports works just fine.