Foreman error with windows DHCP server

Hi,

I am pretty new with Foreman and trying to setup one for deployment of bare
metal and VM's in my test lab.

I have successfully installed the foreman with puppet on one of the node
and now trying to configure Foreman version 1.8

We already have a Windows 2008 r2 host which is configured as our DHCP and
DNS server (it's the same server for the test lab network).

I followed the steps in the manual and downloaded smart proxy 1.7.5 ,
installed ruby 1.9.3-p551 and development kit.

As mentioned in the manual executed the puppet ca generate to generate the
license.

Now there are couple of questions regarding the setup.

  1. When i generated the licnese using command "

"puppet ca generate agilitylab.org" --> agilitylab.org is the FQDN of the dhcp server

I saw the license got generated with the agilitylab.org.pem. I renamed them to signed, private and ca and copied in the smart proxy config folder on the windows server. Is this the right way to do this

  1. When i run the below command on the windows DHCP server command window i
    get an error as No such file or directory – bin/smart-proxy.rb (LoadError)

PS C:\smart_proxy\smart-proxy-1.7.5> ruby bin\smart-proxy.rb
C:\Ruby193\bin\ruby.exe: No such file or directory – bin/smart-proxy.rb
(LoadError)

  1. Can i have a different PXEboot server than DHCP as i don't want to mess
    around with my DHCP server. All my lab servers use this and don't want to
    put this into a bad state

  2. How can i configure DNS which is running on Windows server (actually
    it's the same server as DHCP) ?

Will appreciate any help on this ?

Thanks
Gagan

Any suggestions ?

··· On Monday, May 11, 2015 at 11:03:39 PM UTC-7, Gagan wrote: > > Hi, > > I am pretty new with Foreman and trying to setup one for deployment of > bare metal and VM's in my test lab. > > I have successfully installed the foreman with puppet on one of the node > and now trying to configure Foreman version 1.8 > > We already have a Windows 2008 r2 host which is configured as our DHCP and > DNS server (it's the same server for the test lab network). > > I followed the steps in the manual and downloaded smart proxy 1.7.5 , > installed ruby 1.9.3-p551 and development kit. > > As mentioned in the manual executed the puppet ca generate to generate the > license. > > Now there are couple of questions regarding the setup. > > 1. When i generated the licnese using command " > > "puppet ca generate agilitylab.org" --> agilitylab.org is the FQDN of the dhcp server > > I saw the license got generated with the agilitylab.org.pem. I renamed them to signed, private and ca and copied in the smart proxy config folder on the windows server. Is this the right way to do this > > > 2. When i run the below command on the windows DHCP server command window > i get an error as No such file or directory -- bin/smart-proxy.rb > (LoadError) > > PS C:\smart_proxy\smart-proxy-1.7.5> ruby bin\smart-proxy.rb > C:\Ruby193\bin\ruby.exe: No such file or directory -- bin/smart-proxy.rb > (LoadError) > > 3. Can i have a different PXEboot server than DHCP as i don't want to mess > around with my DHCP server. All my lab servers use this and don't want to > put this into a bad state > > 4. How can i configure DNS which is running on Windows server (actually > it's the same server as DHCP) ? > > Will appreciate any help on this ? > > Thanks > Gagan >

Hi,

I noticed that there is one file name "smart_proxy.rb" in /lib directory
where in smart-proxy 1.8 folder. I am not sure if the steps in manual refer
to this file ? the file name has "underscore" instead of "-". But that too
fails with below error.

I am using a windows server (which is not a DHCP server) this time
different than the one in the previous post.

I am kind of stuck with this and not sure how to proceed.

C:\smart-proxy-1.8.0>ruby lib\smart_proxy.rb
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require': cannot load such file -- proxy (LoadError) from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i nrequire'
from lib/smart_proxy.rb:3:in `<main>'

Thanks
Gagan

This is a typo, you should read "ruby bin\smart-proxy"

Claer

··· On Tue, May 12 2015 at 49:16, Gagan wrote: > Hi, > > I noticed that there is one file name "smart_proxy.rb" in /lib directory > where in smart-proxy 1.8 folder. I am not sure if the steps in manual refer > to this file ? the file name has "underscore" instead of "-". But that too > fails with below error. > > I am using a windows server (which is not a DHCP server) this time > different than the one in the previous post. > > I am kind of stuck with this and not sure how to proceed. > > C:\smart-proxy-1.8.0>ruby lib\smart_proxy.rb > C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in > `require': > cannot load such file -- proxy (LoadError) > from > C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:i > n `require' > from lib/smart_proxy.rb:3:in `' >

Claer, THANKS … removing the .rb fixed that issue but then i land up in
the issues that was same as Support #10098: Does anyone have an updated procedure to install smart proxy on a Windows Server 2008 R2 OS? - Smart Proxy - Foreman.

After changing my setting.yml i was able to overcome the issues. Now my
command throws up licenses and stops for crtl+C . which according to you is
expected

Now, I have a question regarding the option 60 on the Windows DHCP (for PXE
Boot)

My Windows server where I am installing smart proxy is not DHCP server So
when I login to netsh and issue "dhcp" command it prompt as dhcpclient

C:\smart-proxy-1.8.0>netsh
>dhcp
netsh dhcpclient>

I am not sure how i should handle this? Also, is there any other setting i
need to do make this server as PXEBoot ? since this is not actual dhcp
server so i have to do something on dhcp server ?

Thanks again for your help and comment

-Gagan

··· > This is a typo, you should read "ruby bin\smart-proxy" > > Claer > >

Gagan,

For the netsh issue that you're experiencing, you're missing the "DHCP
Server Tools" from your system. In "Server Manager", add "DHCP Server
Tools" under "Remote Server Administration Tools" -> "Role Administration
Tools".

Your foreman server can act as the PXEboot host. The only thing you should
need the windows smart proxy for is interacting with DHCP.

-Matt

··· On Wednesday, May 13, 2015 at 6:26:07 PM UTC-4, Gagan wrote: > > Claer, THANKS ..... removing the .rb fixed that issue but then i land up > in the issues that was same as http://projects.theforeman.org/issues/10098 > . > > After changing my setting.yml i was able to overcome the issues. Now my > command throws up licenses and stops for crtl+C . which according to you is > expected > > Now, I have a question regarding the option 60 on the Windows DHCP (for > PXE Boot) > > My Windows server where I am installing smart proxy is not DHCP server So > when I login to netsh and issue "dhcp" command it prompt as dhcpclient > > C:\smart-proxy-1.8.0>netsh > >dhcp > netsh dhcpclient> > > I am not sure how i should handle this? Also, is there any other setting i > need to do make this server as PXEBoot ? since this is not actual dhcp > server so i have to do something on dhcp server ? > > Thanks again for your help and comment > > -Gagan > > >> This is a typo, you should read "ruby bin\smart-proxy" >> >> Claer >> >>

Thanks Matt,

Appreciate your help. Do you have some link that can help me configuring my
foreman server as PXEboot host. I did not find a direct way in foreman GUI
that can do that. Do i have to install additional smart proxy on the
foreman host for that ?

Thanks
Gagan

Yes, when you installed foreman, you should have had the option to run a
local smart proxy (there's documentation somewhere about setting it up
after the fact), but essentially you're looking for the TFTP feature.

··· On Fri, May 15, 2015 at 1:48 PM, Gagan wrote:

Thanks Matt,

Appreciate your help. Do you have some link that can help me configuring
my foreman server as PXEboot host. I did not find a direct way in foreman
GUI that can do that. Do i have to install additional smart proxy on the
foreman host for that ?

Thanks
Gagan


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.

Ohhh ok. my Foreman server is running two smart proxy at this point. Puppet
and TFTP. that means i am already set for PXEBoot using my foreman host.

Another question. While setting the DHCP server on windows 2008 host when i
run the last step "*extra\query.rb", *I am getting some kind of error

C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require&#39;: cannot load such file -- rest-client (LoadError) from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire'
from C:/smart-proxy-1.8.0/extra/query.rb:32:in `<main>'

Also, when I try to use https://foremanhost.com:8443 on the DHCP server it
doesn't connect to the foreman host. I guess this should work once i have
set up SSL licensing on the DHCP server.

Thanks
Gagan

··· On Friday, May 15, 2015 at 10:58:18 AM UTC-7, Matt Chesler wrote: > > Yes, when you installed foreman, you should have had the option to run a > local smart proxy (there's documentation somewhere about setting it up > after the fact), but essentially you're looking for the TFTP feature. > > On Fri, May 15, 2015 at 1:48 PM, Gagan > wrote: > >> >> Thanks Matt, >> >> Appreciate your help. Do you have some link that can help me configuring >> my foreman server as PXEboot host. I did not find a direct way in foreman >> GUI that can do that. Do i have to install additional smart proxy on the >> foreman host for that ? >> >> Thanks >> Gagan >> >> -- >> You received this message because you are subscribed to a topic in the >> Google Groups "Foreman users" group. >> To unsubscribe from this topic, visit >> https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. >> To unsubscribe from this group and all its topics, send an email to >> foreman-user...@googlegroups.com . >> To post to this group, send email to forema...@googlegroups.com >> . >> Visit this group at http://groups.google.com/group/foreman-users. >> For more options, visit https://groups.google.com/d/optout. >> > >

Hi Gagan,

I haven't used the extra\query.rb tool and I'm not sure how well it's
documented, but the error you're getting is due to the rest-client gem not
being installed on your system. I'm not sure what you mean by "use
https://foremanhost.com:8443".

Best,

Matt

··· On Mon, May 18, 2015 at 12:48 PM, Gagan wrote:

Ohhh ok. my Foreman server is running two smart proxy at this point.
Puppet and TFTP. that means i am already set for PXEBoot using my foreman
host.

Another question. While setting the DHCP server on windows 2008 host when
i run the last step “*extra\query.rb”, *I am getting some kind of error

C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require': cannot load such file -- rest-client (LoadError) from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire’
from C:/smart-proxy-1.8.0/extra/query.rb:32:in `’

Also, when I try to use https://foremanhost.com:8443 on the DHCP server
it doesn’t connect to the foreman host. I guess this should work once i
have set up SSL licensing on the DHCP server.

Thanks
Gagan

On Friday, May 15, 2015 at 10:58:18 AM UTC-7, Matt Chesler wrote:

Yes, when you installed foreman, you should have had the option to run a
local smart proxy (there’s documentation somewhere about setting it up
after the fact), but essentially you’re looking for the TFTP feature.

On Fri, May 15, 2015 at 1:48 PM, Gagan vyas.agi...@gmail.com wrote:

Thanks Matt,

Appreciate your help. Do you have some link that can help me configuring
my foreman server as PXEboot host. I did not find a direct way in foreman
GUI that can do that. Do i have to install additional smart proxy on the
foreman host for that ?

Thanks
Gagan


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-user...@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.

Hi Matt,

I was trying to add this DHCP server in my smart proxy list on the foreman
server. It need a name and url. to verify the URL, I went to the browser
and gave the https:\dhcp-testlab.org:8443 but that doesn't connect.

Then i tried connecting to foreman host from the windows DHCP server using
https://foreman.testlab.org and that doesn't connect as well.

Do i have to install puppet agent on the DHCP server ? since the SSL
certificate is generated using puppet, i am not sure if DHCP server need a
puppet agent ?

Thanks
Gagan

Looks like I was able to figure out one part of it

After i run the command "ruby bin\smart-proxy", i was able to connect the
DHCP using https://dhcp-testlab.org . But when i try to add the smart proxy
to to the foreman using this url, i get the below error

Unable to save
Unable to communicate with the proxy: ERF12-2530
[ProxyAPI::ProxyException]: Unable to detect features
([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read
server session ticket A: tlsv1 alert un…) for proxy
https://dhcp-testlab.org:8443/features
Please check the proxy is configured and running on the host.

However, on the DHCP I still cannot run https://foreman.testlab.org

Thanks
Gagan

··· On Monday, May 18, 2015 at 12:25:15 PM UTC-7, Gagan wrote: > > Hi Matt, > > I was trying to add this DHCP server in my smart proxy list on the foreman > server. It need a name and url. to verify the URL, I went to the browser > and gave the https:\\dhcp-testlab.org:8443 but that doesn't connect. > > Then i tried connecting to foreman host from the windows DHCP server using > https://foreman.testlab.org and that doesn't connect as well. > > Do i have to install puppet agent on the DHCP server ? since the SSL > certificate is generated using puppet, i am not sure if DHCP server need a > puppet agent ? > > Thanks > Gagan >

Did you generate and configure the ssl certificates on your smart proxy?

··· > On May 18, 2015, at 5:02 PM, Gagan wrote: > > Looks like I was able to figure out one part of it > > After i run the command "ruby bin\smart-proxy", i was able to connect the DHCP using https://dhcp-testlab.org . But when i try to add the smart proxy to to the foreman using this url, i get the below error > > Unable to save > Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read server session ticket A: tlsv1 alert un...) for proxy https://dhcp-testlab.org:8443/features > Please check the proxy is configured and running on the host. > > However, on the DHCP I still cannot run https://foreman.testlab.org > > Thanks > Gagan > >> On Monday, May 18, 2015 at 12:25:15 PM UTC-7, Gagan wrote: >> Hi Matt, >> >> I was trying to add this DHCP server in my smart proxy list on the foreman server. It need a name and url. to verify the URL, I went to the browser and gave the https:\\dhcp-testlab.org:8443 but that doesn't connect. >> >> Then i tried connecting to foreman host from the windows DHCP server using https://foreman.testlab.org and that doesn't connect as well. >> >> Do i have to install puppet agent on the DHCP server ? since the SSL certificate is generated using puppet, i am not sure if DHCP server need a puppet agent ? >> >> Thanks >> Gagan > > -- > You received this message because you are subscribed to a topic in the Google Groups "Foreman users" group. > To unsubscribe from this topic, visit https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. > To unsubscribe from this group and all its topics, send an email to foreman-users+unsubscribe@googlegroups.com. > To post to this group, send email to foreman-users@googlegroups.com. > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/d/optout.

Hi Matt,

There was an issue with my certificate and i got this working too now. I
was able to successfully add the Windows DHCP smart proxy on the foreman
host.

But, do i have to keep running "ruby bin\smart-proxy" all the time ? I can
connect to DHCP through https only when this is running. Is there no
separate service which i can run on windows ?

Thanks
Gagan

··· On Monday, May 18, 2015 at 2:05:30 PM UTC-7, Matt Chesler wrote: > > Did you generate and configure the ssl certificates on your smart proxy? > > On May 18, 2015, at 5:02 PM, Gagan <vyas.agi...@gmail.com > > wrote: > > Looks like I was able to figure out one part of it > > After i run the command "ruby bin\smart-proxy", i was able to connect the > DHCP using https://dhcp-testlab.org . But when i try to add the smart > proxy to to the foreman using this url, i get the below error > > Unable to save > Unable to communicate with the proxy: ERF12-2530 > [ProxyAPI::ProxyException]: Unable to detect features > ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read > server session ticket A: tlsv1 alert un...) for proxy > https://dhcp-testlab.org:8443/features > Please check the proxy is configured and running on the host. > > However, on the DHCP I still cannot run https://foreman.testlab.org > > Thanks > Gagan > > On Monday, May 18, 2015 at 12:25:15 PM UTC-7, Gagan wrote: >> >> Hi Matt, >> >> I was trying to add this DHCP server in my smart proxy list on the >> foreman server. It need a name and url. to verify the URL, I went to the >> browser and gave the https:\\dhcp-testlab.org:8443 but that doesn't >> connect. >> >> Then i tried connecting to foreman host from the windows DHCP server >> using https://foreman.testlab.org and that doesn't connect as well. >> >> Do i have to install puppet agent on the DHCP server ? since the SSL >> certificate is generated using puppet, i am not sure if DHCP server need a >> puppet agent ? >> >> Thanks >> Gagan >> > -- > You received this message because you are subscribed to a topic in the > Google Groups "Foreman users" group. > To unsubscribe from this topic, visit > https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. > To unsubscribe from this group and all its topics, send an email to > foreman-user...@googlegroups.com . > To post to this group, send email to forema...@googlegroups.com > . > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/d/optout. > >

You should be able to install the smart proxy as a service. The user that runs the service will need to be a member of the dhcp admins group.

··· > On May 18, 2015, at 5:22 PM, Gagan wrote: > > Hi Matt, > > There was an issue with my certificate and i got this working too now. I was able to successfully add the Windows DHCP smart proxy on the foreman host. > > But, do i have to keep running "ruby bin\smart-proxy" all the time ? I can connect to DHCP through https only when this is running. Is there no separate service which i can run on windows ? > > > Thanks > Gagan > > >> On Monday, May 18, 2015 at 2:05:30 PM UTC-7, Matt Chesler wrote: >> Did you generate and configure the ssl certificates on your smart proxy? >> >>> On May 18, 2015, at 5:02 PM, Gagan wrote: >>> >>> Looks like I was able to figure out one part of it >>> >>> After i run the command "ruby bin\smart-proxy", i was able to connect the DHCP using https://dhcp-testlab.org . But when i try to add the smart proxy to to the foreman using this url, i get the below error >>> >>> Unable to save >>> Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read server session ticket A: tlsv1 alert un...) for proxy https://dhcp-testlab.org:8443/features >>> Please check the proxy is configured and running on the host. >>> >>> However, on the DHCP I still cannot run https://foreman.testlab.org >>> >>> Thanks >>> Gagan >>> >>>> On Monday, May 18, 2015 at 12:25:15 PM UTC-7, Gagan wrote: >>>> Hi Matt, >>>> >>>> I was trying to add this DHCP server in my smart proxy list on the foreman server. It need a name and url. to verify the URL, I went to the browser and gave the https:\\dhcp-testlab.org:8443 but that doesn't connect. >>>> >>>> Then i tried connecting to foreman host from the windows DHCP server using https://foreman.testlab.org and that doesn't connect as well. >>>> >>>> Do i have to install puppet agent on the DHCP server ? since the SSL certificate is generated using puppet, i am not sure if DHCP server need a puppet agent ? >>>> >>>> Thanks >>>> Gagan >>> >>> -- >>> You received this message because you are subscribed to a topic in the Google Groups "Foreman users" group. >>> To unsubscribe from this topic, visit https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. >>> To unsubscribe from this group and all its topics, send an email to foreman-user...@googlegroups.com. >>> To post to this group, send email to forema...@googlegroups.com. >>> Visit this group at http://groups.google.com/group/foreman-users. >>> For more options, visit https://groups.google.com/d/optout. > > -- > You received this message because you are subscribed to a topic in the Google Groups "Foreman users" group. > To unsubscribe from this topic, visit https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. > To unsubscribe from this group and all its topics, send an email to foreman-users+unsubscribe@googlegroups.com. > To post to this group, send email to foreman-users@googlegroups.com. > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/d/optout.

when i try to register the service it still gives me error

C:\smart-proxy-1.8.0>ruby extra\register-service.rb
extra/register-service.rb:2:in `<main>': uninitialized constant PLATFORM
(NameError)

··· On Monday, May 18, 2015 at 2:58:13 PM UTC-7, Matt Chesler wrote: > > You should be able to install the smart proxy as a service. The user that > runs the service will need to be a member of the dhcp admins group. > > On May 18, 2015, at 5:22 PM, Gagan <vyas.agi...@gmail.com > > wrote: > > Hi Matt, > > There was an issue with my certificate and i got this working too now. I > was able to successfully add the Windows DHCP smart proxy on the foreman > host. > > But, do i have to keep running "ruby bin\smart-proxy" all the time ? I can > connect to DHCP through https only when this is running. Is there no > separate service which i can run on windows ? > > > Thanks > Gagan > > > On Monday, May 18, 2015 at 2:05:30 PM UTC-7, Matt Chesler wrote: >> >> Did you generate and configure the ssl certificates on your smart proxy? >> >> On May 18, 2015, at 5:02 PM, Gagan wrote: >> >> Looks like I was able to figure out one part of it >> >> After i run the command "ruby bin\smart-proxy", i was able to connect the >> DHCP using https://dhcp-testlab.org . But when i try to add the smart >> proxy to to the foreman using this url, i get the below error >> >> Unable to save >> Unable to communicate with the proxy: ERF12-2530 >> [ProxyAPI::ProxyException]: Unable to detect features >> ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read >> server session ticket A: tlsv1 alert un...) for proxy >> https://dhcp-testlab.org:8443/features >> Please check the proxy is configured and running on the host. >> >> However, on the DHCP I still cannot run https://foreman.testlab.org >> >> Thanks >> Gagan >> >> On Monday, May 18, 2015 at 12:25:15 PM UTC-7, Gagan wrote: >>> >>> Hi Matt, >>> >>> I was trying to add this DHCP server in my smart proxy list on the >>> foreman server. It need a name and url. to verify the URL, I went to the >>> browser and gave the https:\\dhcp-testlab.org:8443 but that doesn't >>> connect. >>> >>> Then i tried connecting to foreman host from the windows DHCP server >>> using https://foreman.testlab.org and that doesn't connect as well. >>> >>> Do i have to install puppet agent on the DHCP server ? since the SSL >>> certificate is generated using puppet, i am not sure if DHCP server need a >>> puppet agent ? >>> >>> Thanks >>> Gagan >>> >> -- >> You received this message because you are subscribed to a topic in the >> Google Groups "Foreman users" group. >> To unsubscribe from this topic, visit >> https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. >> To unsubscribe from this group and all its topics, send an email to >> foreman-user...@googlegroups.com. >> To post to this group, send email to forema...@googlegroups.com. >> Visit this group at http://groups.google.com/group/foreman-users. >> For more options, visit https://groups.google.com/d/optout. >> >> -- > You received this message because you are subscribed to a topic in the > Google Groups "Foreman users" group. > To unsubscribe from this topic, visit > https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. > To unsubscribe from this group and all its topics, send an email to > foreman-user...@googlegroups.com . > To post to this group, send email to forema...@googlegroups.com > . > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/d/optout. > >

Hi Gagan,

That's a known issue that has been fixed and merged and I believe should be part of the release. In the meantime, if you open extra\register-service.rb and change "PLATFORM" to "RUBY_PLATFORM", the script should work fine.

-Matt

··· > On May 18, 2015, at 9:13 PM, Gagan wrote: > > when i try to register the service it still gives me error > > C:\smart-proxy-1.8.0>ruby extra\register-service.rb > extra/register-service.rb:2:in `': uninitialized constant PLATFORM (NameError) > >> On Monday, May 18, 2015 at 2:58:13 PM UTC-7, Matt Chesler wrote: >> You should be able to install the smart proxy as a service. The user that runs the service will need to be a member of the dhcp admins group. >> >>> On May 18, 2015, at 5:22 PM, Gagan wrote: >>> >>> Hi Matt, >>> >>> There was an issue with my certificate and i got this working too now. I was able to successfully add the Windows DHCP smart proxy on the foreman host. >>> >>> But, do i have to keep running "ruby bin\smart-proxy" all the time ? I can connect to DHCP through https only when this is running. Is there no separate service which i can run on windows ? >>> >>> >>> Thanks >>> Gagan >>> >>> >>>> On Monday, May 18, 2015 at 2:05:30 PM UTC-7, Matt Chesler wrote: >>>> Did you generate and configure the ssl certificates on your smart proxy? >>>> >>>>> On May 18, 2015, at 5:02 PM, Gagan wrote: >>>>> >>>>> Looks like I was able to figure out one part of it >>>>> >>>>> After i run the command "ruby bin\smart-proxy", i was able to connect the DHCP using https://dhcp-testlab.org . But when i try to add the smart proxy to to the foreman using this url, i get the below error >>>>> >>>>> Unable to save >>>>> Unable to communicate with the proxy: ERF12-2530 [ProxyAPI::ProxyException]: Unable to detect features ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read server session ticket A: tlsv1 alert un...) for proxy https://dhcp-testlab.org:8443/features >>>>> Please check the proxy is configured and running on the host. >>>>> >>>>> However, on the DHCP I still cannot run https://foreman.testlab.org >>>>> >>>>> Thanks >>>>> Gagan >>>>> >>>>>> On Monday, May 18, 2015 at 12:25:15 PM UTC-7, Gagan wrote: >>>>>> Hi Matt, >>>>>> >>>>>> I was trying to add this DHCP server in my smart proxy list on the foreman server. It need a name and url. to verify the URL, I went to the browser and gave the https:\\dhcp-testlab.org:8443 but that doesn't connect. >>>>>> >>>>>> Then i tried connecting to foreman host from the windows DHCP server using https://foreman.testlab.org and that doesn't connect as well. >>>>>> >>>>>> Do i have to install puppet agent on the DHCP server ? since the SSL certificate is generated using puppet, i am not sure if DHCP server need a puppet agent ? >>>>>> >>>>>> Thanks >>>>>> Gagan >>>>> >>>>> -- >>>>> You received this message because you are subscribed to a topic in the Google Groups "Foreman users" group. >>>>> To unsubscribe from this topic, visit https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. >>>>> To unsubscribe from this group and all its topics, send an email to foreman-user...@googlegroups.com. >>>>> To post to this group, send email to forema...@googlegroups.com. >>>>> Visit this group at http://groups.google.com/group/foreman-users. >>>>> For more options, visit https://groups.google.com/d/optout. >>> >>> -- >>> You received this message because you are subscribed to a topic in the Google Groups "Foreman users" group. >>> To unsubscribe from this topic, visit https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. >>> To unsubscribe from this group and all its topics, send an email to foreman-user...@googlegroups.com. >>> To post to this group, send email to forema...@googlegroups.com. >>> Visit this group at http://groups.google.com/group/foreman-users. >>> For more options, visit https://groups.google.com/d/optout. > > -- > You received this message because you are subscribed to a topic in the Google Groups "Foreman users" group. > To unsubscribe from this topic, visit https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. > To unsubscribe from this group and all its topics, send an email to foreman-users+unsubscribe@googlegroups.com. > To post to this group, send email to foreman-users@googlegroups.com. > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/d/optout.

Hi Matt,

I am using ruby 1.9.3-p551 and dev kit DevKit-tdm-32-4.5.2-20111229-1559 as
mentioned in 1.8 manual. Is this correct version ?

Changing it to RUBY_PLATFORM gives me a new error

C:\smart-proxy-1.8.0>ruby extra\register-service.rb
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require&#39;: cannot load such file - (LoadError) from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire'
from extra/register-service.rb:6:in `<main>'

Thanks
Gagan

··· On Monday, May 18, 2015 at 7:36:26 PM UTC-7, Matt Chesler wrote: > > Hi Gagan, > > That's a known issue that has been fixed and merged and I believe should > be part of the release. In the meantime, if you open > extra\register-service.rb and change "PLATFORM" to "RUBY_PLATFORM", the > script should work fine. > > -Matt > > On May 18, 2015, at 9:13 PM, Gagan <vyas.agi...@gmail.com > > wrote: > > when i try to register the service it still gives me error > > C:\smart-proxy-1.8.0>ruby extra\register-service.rb > extra/register-service.rb:2:in `': uninitialized constant PLATFORM > (NameError) > > On Monday, May 18, 2015 at 2:58:13 PM UTC-7, Matt Chesler wrote: >> >> You should be able to install the smart proxy as a service. The user that >> runs the service will need to be a member of the dhcp admins group. >> >> On May 18, 2015, at 5:22 PM, Gagan wrote: >> >> Hi Matt, >> >> There was an issue with my certificate and i got this working too now. I >> was able to successfully add the Windows DHCP smart proxy on the foreman >> host. >> >> But, do i have to keep running "ruby bin\smart-proxy" all the time ? I >> can connect to DHCP through https only when this is running. Is there no >> separate service which i can run on windows ? >> >> >> Thanks >> Gagan >> >> >> On Monday, May 18, 2015 at 2:05:30 PM UTC-7, Matt Chesler wrote: >>> >>> Did you generate and configure the ssl certificates on your smart proxy? >>> >>> On May 18, 2015, at 5:02 PM, Gagan wrote: >>> >>> Looks like I was able to figure out one part of it >>> >>> After i run the command "ruby bin\smart-proxy", i was able to connect >>> the DHCP using https://dhcp-testlab.org . But when i try to add the >>> smart proxy to to the foreman using this url, i get the below error >>> >>> Unable to save >>> Unable to communicate with the proxy: ERF12-2530 >>> [ProxyAPI::ProxyException]: Unable to detect features >>> ([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read >>> server session ticket A: tlsv1 alert un...) for proxy >>> https://dhcp-testlab.org:8443/features >>> Please check the proxy is configured and running on the host. >>> >>> However, on the DHCP I still cannot run https://foreman.testlab.org >>> >>> Thanks >>> Gagan >>> >>> On Monday, May 18, 2015 at 12:25:15 PM UTC-7, Gagan wrote: >>>> >>>> Hi Matt, >>>> >>>> I was trying to add this DHCP server in my smart proxy list on the >>>> foreman server. It need a name and url. to verify the URL, I went to the >>>> browser and gave the https:\\dhcp-testlab.org:8443 but that doesn't >>>> connect. >>>> >>>> Then i tried connecting to foreman host from the windows DHCP server >>>> using https://foreman.testlab.org and that doesn't connect as well. >>>> >>>> Do i have to install puppet agent on the DHCP server ? since the SSL >>>> certificate is generated using puppet, i am not sure if DHCP server need a >>>> puppet agent ? >>>> >>>> Thanks >>>> Gagan >>>> >>> -- >>> You received this message because you are subscribed to a topic in the >>> Google Groups "Foreman users" group. >>> To unsubscribe from this topic, visit >>> https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. >>> To unsubscribe from this group and all its topics, send an email to >>> foreman-user...@googlegroups.com. >>> To post to this group, send email to forema...@googlegroups.com. >>> Visit this group at http://groups.google.com/group/foreman-users. >>> For more options, visit https://groups.google.com/d/optout. >>> >>> -- >> You received this message because you are subscribed to a topic in the >> Google Groups "Foreman users" group. >> To unsubscribe from this topic, visit >> https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. >> To unsubscribe from this group and all its topics, send an email to >> foreman-user...@googlegroups.com. >> To post to this group, send email to forema...@googlegroups.com. >> Visit this group at http://groups.google.com/group/foreman-users. >> For more options, visit https://groups.google.com/d/optout. >> >> -- > You received this message because you are subscribed to a topic in the > Google Groups "Foreman users" group. > To unsubscribe from this topic, visit > https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe. > To unsubscribe from this group and all its topics, send an email to > foreman-user...@googlegroups.com . > To post to this group, send email to forema...@googlegroups.com > . > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/d/optout. > >

Looks like you're missing the highline gem, which was also covered in a
recent pull request (https://github.com/theforeman/smart-proxy/pull/281).

··· On Mon, May 18, 2015 at 10:54 PM, Gagan wrote:

Hi Matt,

I am using ruby 1.9.3-p551 and dev kit DevKit-tdm-32-4.5.2-20111229-1559
as mentioned in 1.8 manual. Is this correct version ?

Changing it to RUBY_PLATFORM gives me a new error

C:\smart-proxy-1.8.0>ruby extra\register-service.rb
C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:in
require': cannot load such file - (LoadError) from C:/Ruby193/lib/ruby/site_ruby/1.9.1/rubygems/custom_require.rb:36:inrequire’
from extra/register-service.rb:6:in `’

Thanks
Gagan

On Monday, May 18, 2015 at 7:36:26 PM UTC-7, Matt Chesler wrote:

Hi Gagan,

That’s a known issue that has been fixed and merged and I believe should
be part of the release. In the meantime, if you open
extra\register-service.rb and change “PLATFORM” to “RUBY_PLATFORM”, the
script should work fine.

-Matt

On May 18, 2015, at 9:13 PM, Gagan vyas.agi...@gmail.com wrote:

when i try to register the service it still gives me error

C:\smart-proxy-1.8.0>ruby extra\register-service.rb
extra/register-service.rb:2:in `’: uninitialized constant PLATFORM
(NameError)

On Monday, May 18, 2015 at 2:58:13 PM UTC-7, Matt Chesler wrote:

You should be able to install the smart proxy as a service. The user
that runs the service will need to be a member of the dhcp admins group.

On May 18, 2015, at 5:22 PM, Gagan vyas.agi...@gmail.com wrote:

Hi Matt,

There was an issue with my certificate and i got this working too now. I
was able to successfully add the Windows DHCP smart proxy on the foreman
host.

But, do i have to keep running “ruby bin\smart-proxy” all the time ? I
can connect to DHCP through https only when this is running. Is there no
separate service which i can run on windows ?

Thanks
Gagan

On Monday, May 18, 2015 at 2:05:30 PM UTC-7, Matt Chesler wrote:

Did you generate and configure the ssl certificates on your smart proxy?

On May 18, 2015, at 5:02 PM, Gagan vyas.agi...@gmail.com wrote:

Looks like I was able to figure out one part of it

After i run the command “ruby bin\smart-proxy”, i was able to connect
the DHCP using https://dhcp-testlab.org . But when i try to add the
smart proxy to to the foreman using this url, i get the below error

Unable to save
Unable to communicate with the proxy: ERF12-2530
[ProxyAPI::ProxyException]: Unable to detect features
([OpenSSL::SSL::SSLError]: SSL_connect returned=1 errno=0 state=SSLv3 read
server session ticket A: tlsv1 alert un…) for proxy
https://dhcp-testlab.org:8443/features
Please check the proxy is configured and running on the host.

However, on the DHCP I still cannot run https://foreman.testlab.org

Thanks
Gagan

On Monday, May 18, 2015 at 12:25:15 PM UTC-7, Gagan wrote:

Hi Matt,

I was trying to add this DHCP server in my smart proxy list on the
foreman server. It need a name and url. to verify the URL, I went to the
browser and gave the https:\dhcp-testlab.org:8443 but that doesn’t
connect.

Then i tried connecting to foreman host from the windows DHCP server
using https://foreman.testlab.org and that doesn’t connect as well.

Do i have to install puppet agent on the DHCP server ? since the SSL
certificate is generated using puppet, i am not sure if DHCP server need a
puppet agent ?

Thanks
Gagan


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
foreman-user...@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-user...@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-user...@googlegroups.com.
To post to this group, send email to forema...@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


You received this message because you are subscribed to a topic in the
Google Groups “Foreman users” group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/foreman-users/uukkGRcfz7c/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/d/optout.


Matt Chesler
(212) 300-3971
mchesler@chesent.com