Foreman fail to kickstart centos7 due to multipath?


just started playing with foreman and ran into an issue.

i had no problems installing centos6.7 via kickstart from my foreman
instance using libvirt to install onto a kvm host.

I tried the same templates and tried to install centos 7.1.1503 however it
keeps failing and getting "Pane is dead" and I noticed one thing in the
program.logs pasted below.

looks like its not finding the /dev/vda or unable to access it. I did the
storage setup just like the one for centos6.7.

06:12:58,701 INFO program: Running… multipath -c /dev/vda
06:12:58,940 DEBUG program: Return code: 1
06:12:59,279 INFO program: Running… dumpe2fs -h /dev/loop1
06:12:59,367 INFO program: dumpe2fs 1.42.9 (28-Dec-2013)
06:12:59,368 INFO program: Filesystem volume name: Anaconda
06:12:59,368 INFO program: Last mounted on: /

06:12:59,936 DEBUG program: Return code: 0
06:12:59,936 INFO program: Running… resize2fs -P /dev/mapper/live-base
06:12:59,958 INFO program: resize2fs 1.42.9 (28-Dec-2013)
06:12:59,958 INFO program: resize2fs: Operation not permitted while trying
to open /dev/mapper/live-

my default partition profile is below

#Dynamic - The below code is to manage the swap size

#get the actual memory installed on the system and divide by 1024 to get it
in MB
usable_ram=$((awk '$1 ~ /^MemTotal/ {printf "%d\n", $2 / 1024}' /proc/meminfo))

#check if the memory is less than 2GB then swap is double the memory else
it is maximum 24 G for really inactive stuff.
if [ "$usable_ram" -le 2048 ]; then
swap_size=$(($usable_ram * 2))
swap_size=$(($usable_ram + 2048))
if [ $swap_size -gt 24576 ] ; then

#copy all the HDD partitions to the temp file for execution
cat << EOF > /tmp/diskpart.cfg
clearpart --all --initlabel --drives=vda
ignoredisk --only-use=vda
part /boot --fstype ext4 --size 150 --asprimary
part pv.01 --size=1 --grow
volgroup localvg pv.01
logvol swap --fstype swap --vgname=localvg --name=swap --size=$swap_size
logvol / --fstype ext4 --vgname=localvg --name=root --size=1 --grow