Foreman-installer_1.15.6-1_all.deb size mismatch

I try to install foreman 1.15 on debian jessie (
when I run : apt-get -y install foreman-installer
I obtain :
Failed to fetch Size mismatch
Is there un problem with the repo ?


I did regenerate the cache yesterday, I wonder if that could be an issue. Right now I’m unable to reproduce it on a fresh docker container. Maybe you need to apt update?

It is not an issue. I just tried apt-get clean && apt-get -y install foreman-installer and the problem persist with the same message :frowning:

Hi @kiki,

I can’t reproduce your error here in a fresh Debian Jessie Docker container.

Is there, by any chance a proxy between you and the Internet, that could do something bad to the packages?


Hi @evgeni
I’m behind a proxy. It is possible (I will be very surprised). I will try tonight at home without proxy.
Thanks for your answer.
See you tomorrow.

You could also try installing apt-transport-https and using https in the sources.list entries, which might overcome your proxy :wink:

Hi Evgeni.
so, I installed a fresh jessie at home and I installed with success foreman. Cool.
So, at work, I did the same things (fresh jessie install) and I change also the proxy (we have 2 proxies) and I could install with SUCCESS :-). I don’t know where was the problem (my old jessie or the first proxy) but whatever …
Thanks everyone for yours answers.

Cool, thanks for letting us know.