Foreman-installer is not working

Problem:
I uninstalled foreman* tfm* rubygems* because I foreman would not start. I performed the following on on my RedHat 7 systems and now it cat find the kafo.rb gem.

yum install foreman-installer
** NOTE: This command installed all of the needed rubygems ** I can see them all in the /usr/share/gems/gems/ directory.

When I run the following I get this error.

foreman-installer

/usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:in require': cannot load such file -- kafo (LoadError) from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:55:inrequire’
from /sbin/foreman-installer:3:in `’

When I run

gem list

*** LOCAL GEMS ***

genpasswd (1.0)

I dont see any of the gems that are installed in the /usr/share/gems/gems/ directory.

How do I get the gem command to read the directory?

Foreman and Proxy versions:
version 1.19
Foreman and Proxy plugin versions:
version 1.19

Normally this is installed by rubygem-kafo. Can you verify it with rpm -qV rubygem-kafo?

Yes, its installed.

I’m not sure whats going on.

I uninstalled the foreman-installer and that removed ruby and rubygems.

I reinstalled ONLY ruby and and that installed rubygems and a few gems. When I ran the ‘gem list’ command I still did not see the gems registering as installed. When I cd into the /usr/share/gems/gems/ directory I can see all of the files listed like before. The physical files are getting installed - Its just that the gems database “or what-ever” is not getting updated.

Does anybody know how to force the system to recognize the installed gems?

ruby version 2.0.0.648-33
rubygems 2.0.14.1-33

Clarence

I was able to get it to work.

It appears that my environment variables for RUBY_HOME and PATH were all messed up and pointing to the wrong versions.

1 Like