Foreman-installer steps on my /etc/yum.repos.d/epel.repo, trying use a local repo?

I didn’t want to pound on the remote epel repository while I am working on automating my Foreman install. I also have networks that don’t have internet access so I wanted to be able to install in those locations as well.

Is there some kind of switch or argument that I could pass to not have the foreman-installer reload the epel repository?

I thought I had it working and then I tried to do an install in a network that didn’t have access and it would break the install because it couldn’t get to the epel repository. I ended up modifying the epel.repo file during the install to get it to work. It was pretty much a race condition that I would like to not deal with. The other option might be to just install the epel rpm’s before if that might satisfy some condition, but that seems like that might not work either.

I am doing this on RHEL 7.

Thanks in advance for any suggestions!

Try the --foreman-configure-epel-repo option to the installer, which is a boolean (and obviously defaults to True)

If you’re using Ansible to automate it then bonus points for using :wink:

I wasn’t sure how to use that --foreman-configure-epel-repo option, so I googled it and found.
–foreman-configure-epel-repo=false and then there was a note to make sure your epel repository was working if you do that. I will give it a try.

I tried the --foreman-configure-epel-repo false and it worked great and left the epel.repo alone so that it didn’t hang up on not being able to get to the internet.
Thanks for your help!