Foreman-maintain advanced procedure run content-prepare

**Problem:enable/setup remote execution plug-in

**Expected outcome:able to run remote execution on managed remote hosts

**Foreman and Proxy versions:1.24.2

**Foreman and Proxy plugin versions:1.24.2,

Distribution and version:

Other relevant data:

@leer your post doesn’t really give any details into what happened and as such I don’t think anyone can provide you any guidance. Did you follow the instructions at https://theforeman.org/plugins/foreman_remote_execution/1.7/index.html#2.Installation ?

1 Like

**Problem:
upgrade katello from 3.14 to 3.15, When attempt to migrate to Pulp 3 for both command:
foreman-maintain advanced procedure run content-prepare
foreman-maintain advanced procedure run content-switchover

both failed w errors:
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.15.3.1/lib/katello/tasks/pulp3_migration.rake:15:in block (2 levels) in <top (required)>' /opt/rh/rh-ruby25/root/usr/share/gems/gems/rake-12.3.0/exe/rake:27:in <top (required)>’

Need help please.

**Expected outcome:
migrate to Pulp3

**Foreman and Proxy versions:3.15

**Foreman and Proxy plugin versions:3.15

Distribution and version:

**Other relevant data:

foreman-maintain advanced procedure run content-prepare

Running ForemanMaintain::Scenario

Prepare content for Pulp 3: [FAIL]
Failed executing foreman-rake katello:pulp3_migration, exit status 1:
rake aborted!
ForemanTasks::TaskError: Task 0aa21641-cc68-4913-b887-41d1d7fbb01e: Katello::Errors::Pulp3MigrationError: Pulp 3 migration cannot run. Types file, docker have already been migrated.
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.15.3.1/lib/katello/tasks/pulp3_migration.rake:15:in block (2 levels) in <top (required)>' /opt/rh/rh-ruby25/root/usr/share/gems/gems/rake-12.3.0/exe/rake:27:in <top (required)>’
Tasks: TOP => katello:pulp3_migration
(See full trace by running task with --trace)

Scenario [ForemanMaintain::Scenario] failed.

The following steps ended up in failing state:

[content-prepare]

Resolve the failed steps and rerun
the command. In case the failures are false positives,
use --whitelist=“content-prepare”

I personally don’t see anything that jumps out at me but I am just a lowly user/admin like yourself. Maybe run it again with --trace like the error said and see if that gives you any clues. If not you may want to paste it here (or use a pastebin link) so smarter people than I won’t have to ask for it later :D.

1 Like

I tried: foreman-maintain advanced procedure run content-prepare --trace
and I got:
ERROR: Unrecognised option ‘–trace’
It doesn’t look like its a oreman-maintain command line option. can someone please shed some light ?

My foreman (with katello and remote execution plugins) GUI->Infrastructure->Smart Proxies->services:
Pulp
Version2.0.0
Pulp server version2.21.3

Pulpcore
Version2.0.0
Supported Content Types
docker
file

So I think I need to migrate pulp2 to pult3.

The error message “<top (required)” seems indicate it missing something. How do i run the “content-prepare” with trace to get some hints? Thanks.