Foreman not recognizing class parameter custom type

class parameter “$myclass” is not recognized by foreman import function.

cat .manifests/myclass.pp

class mymodule::myclass (
     Ssh::YesNo $myvar = 'yes',

cat ./types/yesno.pp

type Ssh::YesNo = Enum[
  'no' # lint:ignore:trailing_comma

I’m not even sure what that parameter type (Ssh::YesNo) is referred to, but is there a way to get Foreman to recognize it?

Expected outcome:
be able to import in Foreman, and see this class parameter $myvar in the Foreman “Smart Class Parameter” tab of the class edit page.

Foreman and Proxy versions:

Foreman and Proxy plugin versions:


Never mind, I realize I was looking at the wrong code.
I don’t know how to delete my post

We don’t generally delete posts, as they form part of the historical record of the community. Others may still benefit from such posts (to a greater or lesser degree :P). Glad you got it fixed!