Foreman passenger config obscuring cobbler?

I've installed Foreman and it now appears that its default config has it
snarfing up some of the URLs that had formerly been served and managed by
Cobbler. To wit:

http://gepetto.my.com/cobbler/repo_mirror/

This results in a Ruby (Rack) application could not be started error (this
has never started cleanly for me – it's either an sqlite3 error or a
missing directory or a missing somethingorother that prevents it from
launching cleanly, and it's something new every few days, but I'm hanging
in there hoping I'll get it all nailed down).

My /etc/httpd/conf.d/cobbler.conf still contains, in part:

AliasMatch ^/cobbler(.*)?$ "/var/www/cobbler$1"
Alias /cobbler /var/www/cobbler
:
:
<Directory "/var/www/cobbler">
Options Indexes FollowSymLinks
Order allow, deny
Allow from all
</Directory>

I've tried this with and without the AliasMatch line, btw.

foreman.conf:

<VirtualHost 10.0.0.1:80>
ServerName gepetto.my.com
ServerAlias foreman
DocumentRoot /usr/share/foreman/public
Passenger AppRoot /usr/share/foreman

RailsAutoDetect On
AddDefaultCharSet UTF-8

</VirtualHost>

Plus a similar entry for SSL.

My question is: How can I keep foreman running in Passenger as configured,
because that seems to be working (apart from the application errors) while
giving visibility to my cobbler hierarchy as well? For instance,
http://gepetto.my.com/ should bring up foreman, but
http://gepetto.my.com/cobbler/repo_mirror should bring up the cobbler repo
mirror list.

Thanks!