Foreman provisioning using external DHCP server

Hi
I am trying to provision a host and I don't want to use default dhcp server
provided with foreman. I have configured foreman using puppet and it is
working for unmanaged hosts. I am using next-server functionality of
external dhcp server to direct it to tftp server at foreman. That bit seems
to be working as host is directed to foreman tftp server. dhcp is set to be
false in /etc/foreman-proxy/settings.yml.

Installation does not proceed as there is no mac-address specific file in
pxelinux.cfg. I can't see any error anywhere although I have enabled debug
on foreman. No kernel and initrd files were downloaded as well.

I am using 'Kickstart Default' and 'Kickstart default PXElinux' provided
with installation to install a Fedora 18 macihne

Is it because of external dhcp server ?

Thanks
Kashif

You'll need to install a smart proxy on the external dhcp server.

–Steve

··· ________________________________________ From: foreman-users@googlegroups.com [foreman-users@googlegroups.com] on behalf of kashif.alig@gmail.com [kashif.alig@gmail.com] Sent: Friday, July 26, 2013 9:09 AM To: foreman-users@googlegroups.com Subject: [foreman-users] Foreman provisioning using external DHCP server

Hi
I am trying to provision a host and I don’t want to use default dhcp server provided with foreman. I have configured foreman using puppet and it is working for unmanaged hosts. I am using next-server functionality of external dhcp server to direct it to tftp server at foreman. That bit seems to be working as host is directed to foreman tftp server. dhcp is set to be false in /etc/foreman-proxy/settings.yml.

Installation does not proceed as there is no mac-address specific file in pxelinux.cfg. I can’t see any error anywhere although I have enabled debug on foreman. No kernel and initrd files were downloaded as well.

I am using ‘Kickstart Default’ and ‘Kickstart default PXElinux’ provided with installation to install a Fedora 18 macihne

Is it because of external dhcp server ?

Thanks
Kashif


You received this message because you are subscribed to the Google Groups “Foreman users” group.
To unsubscribe from this group and stop receiving emails from it, send an email to foreman-users+unsubscribe@googlegroups.com.
To post to this group, send email to foreman-users@googlegroups.com.
Visit this group at http://groups.google.com/group/foreman-users.
For more options, visit https://groups.google.com/groups/opt_out.

This email message is for the sole use of the intended recipient(s) and may contain information that is privileged, confidential, and exempt from disclosure under applicable law. Any unauthorized review, use, copying, disclosure or dissemination is prohibited. If you are not the intended recipient, please contact the sender by reply email and destroy all copies of the original message.

If you're missing a mac-file in the tftp folder, then it's the TFTp feature
of your proxy that's not configured correctly, not DHCP. Have you got TFTP
enabled on the proxy? is the Subnet you're associating with the new host
assigned to use that tftp proxy?

Greg

··· On 26 July 2013 16:09, wrote:

Hi
I am trying to provision a host and I don’t want to use default dhcp
server provided with foreman. I have configured foreman using puppet and it
is working for unmanaged hosts. I am using next-server functionality of
external dhcp server to direct it to tftp server at foreman. That bit seems
to be working as host is directed to foreman tftp server. dhcp is set to be
false in /etc/foreman-proxy/settings.yml.

Installation does not proceed as there is no mac-address specific file in
pxelinux.cfg. I can’t see any error anywhere although I have enabled debug
on foreman. No kernel and initrd files were downloaded as well.

I am using ‘Kickstart Default’ and ‘Kickstart default PXElinux’ provided
with installation to install a Fedora 18 macihne

Is it because of external dhcp server ?

Hi Steve

Thanks for your quick response. Is there any document lying around about
installing and configuring smart proxy on separate dhcp server. Would
setting up of smart proxy on DHCP server affects other machines requesting
addresses from DHCP server.

Thanks
Kashif

··· On Friday, July 26, 2013 4:11:34 PM UTC+1, steve.stodola wrote: > > You'll need to install a smart proxy on the external dhcp server. > > --Steve > ________________________________________ > From: forema...@googlegroups.com [forema...@googlegroups.com] > on behalf of kashi...@gmail.com [kashi...@gmail.com] > > Sent: Friday, July 26, 2013 9:09 AM > To: forema...@googlegroups.com > Subject: [foreman-users] Foreman provisioning using external DHCP server > > Hi > I am trying to provision a host and I don't want to use default dhcp > server provided with foreman. I have configured foreman using puppet and it > is working for unmanaged hosts. I am using next-server functionality of > external dhcp server to direct it to tftp server at foreman. That bit seems > to be working as host is directed to foreman tftp server. dhcp is set to be > false in /etc/foreman-proxy/settings.yml. > > Installation does not proceed as there is no mac-address specific file in > pxelinux.cfg. I can't see any error anywhere although I have enabled debug > on foreman. No kernel and initrd files were downloaded as well. > > I am using 'Kickstart Default' and 'Kickstart default PXElinux' provided > with installation to install a Fedora 18 macihne > > Is it because of external dhcp server ? > > Thanks > Kashif > > > -- > You received this message because you are subscribed to the Google Groups > "Foreman users" group. > To unsubscribe from this group and stop receiving emails from it, send an > email to foreman-user...@googlegroups.com . > To post to this group, send email to forema...@googlegroups.com. > > Visit this group at http://groups.google.com/group/foreman-users. > For more options, visit https://groups.google.com/groups/opt_out. > > > This email message is for the sole use of the intended recipient(s) and > may contain information that is privileged, confidential, and exempt from > disclosure under applicable law. Any unauthorized review, use, copying, > disclosure or dissemination is prohibited. If you are not the intended > recipient, please contact the sender by reply email and destroy all copies > of the original message. >

Hi Greg
Thanks a lot. I didn't created subnet earlier. Created the subnet and it
seems to be working.

Cheers
Kashif

··· On Friday, July 26, 2013 4:42:06 PM UTC+1, Greg Sutcliffe wrote: > > On 26 July 2013 16:09, <kashi...@gmail.com > wrote: > >> >> Hi >> I am trying to provision a host and I don't want to use default dhcp >> server provided with foreman. I have configured foreman using puppet and it >> is working for unmanaged hosts. I am using next-server functionality of >> external dhcp server to direct it to tftp server at foreman. That bit seems >> to be working as host is directed to foreman tftp server. dhcp is set to be >> false in /etc/foreman-proxy/settings.yml. >> >> Installation does not proceed as there is no mac-address specific file in >> pxelinux.cfg. I can't see any error anywhere although I have enabled debug >> on foreman. No kernel and initrd files were downloaded as well. >> >> I am using 'Kickstart Default' and 'Kickstart default PXElinux' provided >> with installation to install a Fedora 18 macihne >> >> Is it because of external dhcp server ? >> > > If you're missing a mac-file in the tftp folder, then it's the TFTp > feature of your proxy that's not configured correctly, not DHCP. Have you > got TFTP enabled on the proxy? is the Subnet you're associating with the > new host assigned to use that tftp proxy? > > Greg >