Foreman re-provision host different OS password not working

I am running foreman on latest CentOS 7.8.

I created and then provisioned a bare metal host with CentOS 7.8. The password I entered in during provisioning worked fine after the host booted. Then I wanted to test Ubuntu 20.04. So edited the host changed the OS to Ubuntu 20.04. It would not let me edit the password so I left that. Rebooted the host and it provisioned fine. When it came up though the password I had originally entered in did not work.

So then I cloned the Preseed default template and change the password line to:

d-i passwd/root-password password noroot4u

I rebooted the host and let it re-provision. When it was done and came up the password did not work still.

I now the command above works because I have used that outside of foreman to “kickstart” and Ubuntu server with no issues.

Any idea whats up?

I actually figured that out after I wrote the message and I also found out that the foreman-proxy ssh key worked so I could ssh in using that key.

Thank you.