Foreman smart parameters - need help

All,

I am trying to install a mysql server and change the max_connections to
1024 using this bit of code (below) in site.pp, but when trying to
translate that bit of code into Foreman mysql::server::override_options >
smart variable, I can't seem to get the syntax right! The puppet module I
am using is https://forge.puppetlabs.com/puppetlabs/mysql. Trying to
install on RHEL 7. The error I get is "options is not a hash or array when
accessing it with mysqld". Any help would be greatly appreciated!

class { '::mysql::server':
override_options => { 'mysqld' => { 'max_connections' => '1024'}},
}

Here is my content of the override_options textarea in FM:

mysqld:
basedir: /opt/rh/mysql55/root
datadir: /opt/rh/mysql55/root/var/lib/mysql
socket: /opt/rh/mysql55/root/var/lib/mysql/mysql.sock
pid-file: /opt/rh/mysql55/root/var/run/mysqld/mysqld.pid
log-error: /opt/rh/mysql55/root/var/log/mysql55-mysqld-error.log
log-slow-queries: 1
log-warnings: 2
bind-address: 0.0.0.0
sort_buffer_size: 512K
net_buffer_length: 8K
read_buffer_size: 256K
read_rnd_buffer_size: 512K
myisam_sort_buffer_size: 8M
innodb_log_file_size: 5M
innodb_log_buffer_size: 8M
innodb_flush_log_at_trx_commit: 1
innodb_lock_wait_timeout: 50
innodb_buffer_pool_size: 16M
innodb_additional_mem_pool_size: 2M
mysqld_safe:
socket: /opt/rh/mysql55/root/var/lib/mysql/mysql.sock
pid-file: /opt/rh/mysql55/root/var/run/mysqld/mysqld.pid
log-error: /opt/rh/mysql55/root/var/log/mysql55-mysqld_safe-error.log
log-slow-queries: 1
log-warnings: 2
bind-address: 0.0.0.0
client:
socket: /opt/rh/mysql55/root/var/lib/mysql/mysql.sock

Regards,

Joop

ยทยทยท On 4-6-2015 19:17, Michele Newman wrote: > All, > > I am trying to install a mysql server and change the max_connections > to 1024 using this bit of code (below) in site.pp, but when trying to > translate that bit of code into Foreman > mysql::server::override_options > smart variable, I can't seem to get > the syntax right! The puppet module I am using > is https://forge.puppetlabs.com/puppetlabs/mysql. Trying to install > on RHEL 7. The error I get is "options is not a hash or array when > accessing it with mysqld". Any help would be greatly appreciated! > > class { '::mysql::server': > override_options => { 'mysqld' => { 'max_connections' => '1024'}}, > } > >