Forman 3.1 and ansible Plugin

I wanted to test Foreman 3.1 together with the Ansible plugin before we update on the live system. Now I noticed that when I install the plugin it says it needs ruby 2.5 and not 2.7. Is there a solution for this yet? I use Debian 11

I think that’s outdated documentation because we’ve been shipping (for RPMs) on Ruby 2.7 for a few releases now. Where did you find that exactly?

I followed these instructions Foreman :: Plugin Manuals.
When installing the plugin, it says you are using 2.7 instead of 2.5.

Ok, we should do better with Plugin documentation as the current version is 7.0.2 not 2.x! :frowning:

I do not see what should cause this error, so can you provide the error message as I might look at the wrong locations.

I will gladly make these available to you when I am back home.

I have found a part in a process that I sent to a friend.

 [ERROR ] [configure] ruby-msgpack : Depends: libruby2.5 (>= 2.5.0~preview1) but it is not installable
 [ERROR ] [configure] Depends: ruby (< 1:2.6~) but 1:2.7+2 is to be installed
 [ERROR ] [configure] E: Unable to correct problems, you have held broken packages.
 [ERROR ] [configure] /Stage[main]/Foreman::Plugin::Ansible/Foreman::Plugin[ansible]/Package[ruby-foreman-ansible]/ensure: change from 'purged' to 'present' failed: Execution of '/usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install ruby-foreman-ansible' returned 100: Reading package lists...

Could it be that you are using packages from Debian 10 on Debian 11 as you say Foreman 3.1? While trying to reproduce I recognized Debian 11 has only the upcoming 3.2 and there it installs the package fine, but than hits the bug I hit already yesterday: Enabling ansible plugin results in failure of db:migrate - #7 by Dirk

today I tried the whole thing again with 3.2. With it it went without problems. Thanks

there is also a tutorial how to import rols now