Fresh Foreman install missing smart proxy

I am using the quickstart in the manual for ubuntu 18.04 (Foreman :: Manual). This is a brand-new ec2 instance and there weren’t any errors during the installation. I followed along the instructions in the quick start up until the step to 2.2 Puppet Management without any errors. The first two steps in Puppet Management worked fine, the host shows up in the foreman console as healthy and I was able to install the NTP module with the puppet command.

Trying to do the next step was impossible though. The quickstart says: “go to Configure > Classes and click Import from hostname”. Well that button or link does not appear. I read somewhere that this may be because Foreman can’t communicate with the Smart Proxy so I went to look at that and the smart proxy installed by the installer doesn’t appear on the page at “Infrastructure > Smart Proxies”. I tried to add it but that was rejected as a duplicate, so I think it knows about the smart proxy but can’t use it for some reason. The logs aren’t helpful and I’m not sure what the next troubleshooting step is.

Expected outcome:
quick start document works as expected
Foreman and Proxy versions:

Foreman and Proxy plugin versions:
Foreman 1.22

Other relevant data:
output of foreman debug:

root@ip-172-20-13-172:/var/log/foreman-installer# foreman-debug -u
Processing... (takes a while)

 HOSTNAME: ip-172-20-13-172.ec2.internal
       OS: debian
  RELEASE: buster/sid
  FOREMAN: 1.22.0
     RUBY: ruby 2.5.1p57 (2018-03-29 revision 63029) [x86_64-linux-gnu]
   PUPPET: 6.7.2

A debug file has been created: /var/tmp/foreman-debug-XBNvJ.tar.xz (239192 bytes)

The tarball has been uploaded, please contact us on
or on IRC/Matrix (#theforeman), making sure you reference the following URL:

Propabably the Smart Proxy is in a different context. Can you switch to Any Organization and Any Location via the top bar and look into Infrastructure > Smart Proxies? It should be their and when you edit it, you can place it in the correct context. If you only have one Organization and Location it should be automatically select them, so pressing edit and then submit is enough.

That was it, Thanks Dirk. Did I miss a step in the Quickstart?

It’s a known issue that 1.23 will address. Currently that’s a release candidate.