Getting "400 Bad Request" when trying to remove host entry in Foreman webGUI


In the foreman webgui, I am attempting to delete a VM host entry but I am
getting an error that says: "Remove DHCP Settings for <hostname> task
failed with the following error: 400 Bad Request". This started happening
last week when I removed a host because it wasn't provisioning correctly
and then tried adding it back in with the same configurations. When I
first got the error, I manually removed the VM image, the xml file, its
entries in DNS and dhcpd.leases to no avail.

OS: CentOS release 6.9 (Final)
foreman version: 1.4.2-1.el6
puppet version: 2.7.26

Here's the log entry from /var/log/foreman/production.log for the
aforementioned host I attempted to delete
Started DELETE "/hosts/<host>" for <IP_Address> at 2017-08-30 13:25:42 -0700
Processing by HostsController#destroy as HTML
Parameters: {"authenticity_token"=>"<hash>=", "id"=>"<host FQDN>"}
Binary data inserted for string type on column remote_address
Delete the DNS PTR record for <host_IP>/<host_FQDN>
Delete the DNS A record for <host_FQDN>/<host_IP>
Delete DHCP reservation for <host_FQDN>-<host_MAC>/<host_IP>
Remove DHCP Settings for <host_FQDN> task failed with the following error:
400 Bad

Any ideas what I should do? I get this same error when I am adding a host
or deleting one.

Best thing to do is probably to go to the appropriate DHCP proxy and up
it's logging to "debug" level, and then tail it's logs while performing one
of the failing actions - hopefully that will shed light on what's happening.