Hammer repository-set enable

Using hammer repository-set appears to have broken using --name option. ie:

# hammer repository-set enable --organization ${ORG} --product ‘Red Hat Enterprise Linux Server’ --basearch=‘x86_64’ --releasever=‘7Server’ --name ‘Red Hat Enterprise Linux 7 Server (RPMs)’
**Could not enable repository:**

** Error: repository_set not found**.

Expected outcome:
Repository enabled

Foreman and Proxy versions:

Foreman and Proxy plugin versions:
bastion 6.1.8
foreman-tasks 0.11.2
foreman_ansible 2.0.1
foreman_bootdisk 11.0.0
foreman_cockpit 2.0.3
foreman_default_hostgroup 4.0.1
foreman_discovery 11.0.0
foreman_docker 4.0.0
foreman_hooks 0.3.14
foreman_remote_execution 1.4.5
foreman_setup 6.0.0
katello 3.6.0

Other relevant data:
Using --id=[reponumber] will work, but highly inconvenient.

This --name feature worked flawlessly in previous released Katello versions. 3.3, 3.4, 3.5, 3.5.1, using automation scripts to populate a server.

I’ve tested this on an --upgraded server, and fresh installation. Same result.

You may be hitting this issue, which will be fixed in Katello 3.7.0.